blob: 6ccb425e3816d06ab686bee9cd5c2b937998dd53 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
6
Andrew Geissler69721092021-07-23 12:57:00 -04007inherit autotools gettext systemd gsettings python3native gtk-icon-cache
Brad Bishop26bdd442019-08-16 17:08:17 -04008
9SRC_URI = " \
10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
11 file://0001-Search-for-cython3.patch \
Brad Bishop2d39a062019-10-28 08:33:36 -040012 file://0002-fix-fail-to-enable-bluetooth.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040013"
Andrew Geissler69721092021-07-23 12:57:00 -040014SRC_URI[sha256sum] = "fcc10a2259bef2c5ac63f577010d76caed460d68810b7f70fecf056bf10a1a72"
Brad Bishop26bdd442019-08-16 17:08:17 -040015
16EXTRA_OECONF = " \
Brad Bishope42b3e32020-01-15 22:08:42 -050017 --disable-appindicator \
Brad Bishop26bdd442019-08-16 17:08:17 -040018 --disable-runtime-deps-check \
19 --disable-schemas-compile \
20"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service"
23SYSTEMD_AUTO_ENABLE:${PN} = "disable"
Brad Bishop26bdd442019-08-16 17:08:17 -040024
25RRECOMENDS_${PN} += "adwaita-icon-theme"
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN} += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040027 python3-core \
28 python3-dbus \
29 packagegroup-tools-bluetooth \
30"
31
32PACKAGECONFIG ??= "thunar"
33PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035FILES:${PN} += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040036 ${datadir}/dbus-1 \
37 ${datadir}/Thunar \
38 ${systemd_user_unitdir} \
39 ${exec_prefix}${systemd_system_unitdir} \
40 ${PYTHON_SITEPACKAGES_DIR} \
41"
42
Patrick Williams213cb262021-08-07 19:21:33 -050043FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"
Brad Bishop26bdd442019-08-16 17:08:17 -040044
45# In code, path to python is a variable that is replaced with path to native version of it
46# during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3.
47# Replace it with #!/usr/bin/env python3
Patrick Williams213cb262021-08-07 19:21:33 -050048do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040049 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
50 ${D}${prefix}/libexec/blueman-mechanism \
Andrew Geissler69721092021-07-23 12:57:00 -040051 ${D}${bindir}/blueman-adapters \
Brad Bishop26bdd442019-08-16 17:08:17 -040052 ${D}${bindir}/blueman-applet \
Andrew Geissler69721092021-07-23 12:57:00 -040053 ${D}${bindir}/blueman-manager \
54 ${D}${bindir}/blueman-sendto \
55 ${D}${bindir}/blueman-services \
56 ${D}${bindir}/blueman-tray
Brad Bishop26bdd442019-08-16 17:08:17 -040057}