blob: 7558c314ff7335396844f0e3946dff9b34c3682c [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Dibbler DHCPv6 client"
2DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6."
3HOMEPAGE = "http://klub.com.pl/dhcpv6"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
7
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05008SRCREV = "a7c6cf58a88a510cb00841351e75030ce78d36bf"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009
10SRC_URI = "git://github.com/tomaszmrugalski/dibbler \
11 file://dibbler_fix_getSize_crash.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013PV = "1.0.1+1.0.2RC1+git${SRCREV}"
14
15S = "${WORKDIR}/git"
16
17PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update"
18
19PACKAGECONFIG[debug] = "--enable-debug,,,"
20PACKAGECONFIG[efence] = "--enable-efence,,,"
21PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,,,"
22PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-check,,,"
23PACKAGECONFIG[resolvconf] = "--enable-resolvconf,,,"
24PACKAGECONFIG[dns-update] = "--enable-dns-update,,,"
25PACKAGECONFIG[auth] = "--enable-auth,,,"
26PACKAGECONFIG[gtest] = "--enable-gtest-static,,,"
27
28inherit autotools
29
30DEPENDS += "flex-native"
31
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050032LDFLAGS += "-pthread"
33
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server"
35
Patrick Williams213cb262021-08-07 19:21:33 -050036FILES:${PN}-client = "${sbindir}/${PN}-client"
37FILES:${PN}-relay = "${sbindir}/${PN}-relay"
38FILES:${PN}-requestor = "${sbindir}/${PN}-requestor"
39FILES:${PN}-server = "${sbindir}/${PN}-server"