blob: fa5b4ade8c0ad3f27fd905cc40f72ae3855a416a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "libtalloc libtirpc"
Patrick Williams213cb262021-08-07 19:21:33 -05007RDEPENDS:python3-tevent = "python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
Brad Bishop26bdd442019-08-16 17:08:17 -040010 file://options-0.10.0.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://0001-libtevent-fix-musl-libc-compile-error.patch \
12"
13LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
14
Andrew Geissler72956ed2021-01-08 16:11:14 -060015SRC_URI[md5sum] = "105c7a4dbb96f1751eb27dfd05e7fa84"
16SRC_URI[sha256sum] = "f8427822e5b2878fb8b28d6f50d96848734f3f3130612fb574fdd2d2148a6696"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
18inherit waf-samba
19
20PACKAGECONFIG ??= "\
21 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
22 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
23"
24PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
25PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
26PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
27PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
28PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
29PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
30
31SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
32
33S = "${WORKDIR}/tevent-${PV}"
34
Brad Bishop26bdd442019-08-16 17:08:17 -040035#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
36#to cross Popen
37export WAF_NO_PREFORK="yes"
38
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039EXTRA_OECONF += "--disable-rpath \
40 --bundled-libraries=NONE \
41 --builtin-libraries=replace \
42 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
43 --without-gettext \
44 "
Patrick Williams213cb262021-08-07 19:21:33 -050045do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040046 # add this link for cross check python module existence. eg: on x86-64 host, check python module
47 # under recipe-sysroot which is mips64.
48 cd ${D}${PYTHON_SITEPACKAGES_DIR}; ln -s _tevent.*.so _tevent.so
49}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080050
Brad Bishop26bdd442019-08-16 17:08:17 -040051PACKAGES += "python3-tevent"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052
Patrick Williams213cb262021-08-07 19:21:33 -050053RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054
Patrick Williams213cb262021-08-07 19:21:33 -050055FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
Brad Bishop26bdd442019-08-16 17:08:17 -040056
Patrick Williams213cb262021-08-07 19:21:33 -050057INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"