blob: 422b4d49dfeee4c78d865d0533795434c23ae90a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# This recipe is intended as a 'simpler' replacement for packagegroup-base.
2# Please communicate your use cases and suggestions to the mailinglist(s)
3
4SUMMARY = "Basic task to get a device online"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05005
6PR = "r13"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9inherit packagegroup
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
11# Poke extra recomendations into the list using your machine.conf
12#
13MACHINE_EXTRA_RRECOMMENDS ?= ""
14
15#
16# Select between dropbear and openssh
17# Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp openssh-sftp-server" in your DISTRO config to get openssh(d)
18#
19TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server"
20
21#
Patrick Williamsddad1a12017-02-23 20:36:32 -060022# The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023# when writing image recipes.
24# It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
25# distro feature.
26#
27# Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
28#
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} = "\
Patrick Williamsb48b7b42016-08-17 15:04:38 -050030 ${TASK_BASIC_SSHDAEMON} \
31 avahi-daemon avahi-utils \
32"
33
34#
35# The following section is split in 3:
36# 1) Machine features: kernel modules and userspace helpers for those
37# 2) Distro features: packages associated with those
Patrick Williamsddad1a12017-02-23 20:36:32 -060038# 3) Nice to have: packages that are nice to have, but aren't strictly needed
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039#
Patrick Williams213cb262021-08-07 19:21:33 -050040RRECOMMENDS:${PN} = "\
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041 ${MACHINE_EXTRA_RRECOMMENDS} \
42 ${@bb.utils.contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
43 ${@bb.utils.contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
44 ${@bb.utils.contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
45 \
Brad Bishop26bdd442019-08-16 17:08:17 -040046 ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "bluez5", "", d)} \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050047 ${@bb.utils.contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
48 \
49 tzdata \
50 \
51 cpufrequtils \
52 htop \
53"