blob: ed81859190629559c3258da16da26c6edbe92adf [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Minimalistic C client library for Redis"
2HOMEPAGE = "http://github.com/redis/hiredis"
3LICENSE = "BSD-3-Clause"
4SECTION = "libs"
5DEPENDS = "redis"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d84d659a35c666d23233e54503aaea51"
Brad Bishope42b3e32020-01-15 22:08:42 -05008SRCREV = "685030652cd98c5414ce554ff5b356dfe8437870"
9SRC_URI = "git://github.com/redis/hiredis;protocol=git \
Andrew Geissler69721092021-07-23 12:57:00 -040010 file://0001-Makefile-remove-hardcoding-of-CC.patch \
11 file://0001-CMake-configuration-for-hiredis.patch"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
13S = "${WORKDIR}/git"
14
15inherit autotools-brokensep pkgconfig
16
Brad Bishope42b3e32020-01-15 22:08:42 -050017EXTRA_OEMAKE = "PREFIX=${prefix} LIBRARY_PATH=${baselib}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018
19# By default INSTALL variable in Makefile is equal to 'cp -a', which preserves
20# ownership and causes host-user-contamination QA issue.
21# And PREFIX defaults to /usr/local.
Patrick Williams213cb262021-08-07 19:21:33 -050022do_install:prepend() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023 export INSTALL='cp -r'
24}