blob: 76a749644bdec77e48b2e5b0cd832c551059f5d7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Inspect and manipulate eBPF programs and maps"
2DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
3of eBPF programs and maps."
4LICENSE = "GPLv2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005DEPENDS = "binutils elfutils"
6PROVIDES = "virtual/bpftool"
7
8inherit bash-completion kernelsrc kernel-arch
9
10do_populate_lic[depends] += "virtual/kernel:do_patch"
11
Andrew Geissler32b11992021-03-31 13:37:05 -050012EXTRA_OEMAKE = "\
13 V=1 \
14 -C ${S}/tools/bpf/bpftool \
15 O=${B} \
16 CROSS=${TARGET_PREFIX} \
17 CC="${CC} ${DEBUG_PREFIX_MAP} -fdebug-prefix-map=${STAGING_KERNEL_DIR}=${KERNEL_SRC_PATH}" \
18 LD="${LD}" \
19 AR=${AR} \
20 ARCH=${ARCH} \
21"
Brad Bishop0f291cc2019-09-01 15:16:57 -040022
23SECURITY_CFLAGS = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024
25do_configure[depends] += "virtual/kernel:do_shared_workdir"
26
Andrew Geissler32b11992021-03-31 13:37:05 -050027COMPATIBLE_HOST = "(x86_64).*-linux"
Patrick Williams213cb262021-08-07 19:21:33 -050028COMPATIBLE_HOST:libc-musl = 'null'
Andrew Geissler1548c072019-02-22 16:03:50 -060029
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030do_compile() {
31 oe_runmake
32}
33
34do_install() {
35 oe_runmake DESTDIR=${D} install
36}
37
38PACKAGE_ARCH = "${MACHINE_ARCH}"
39
Patrick Williams213cb262021-08-07 19:21:33 -050040python do_package:prepend() {
Brad Bishop19323692019-04-05 15:28:33 -040041 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042}
43
44B = "${WORKDIR}/${BPN}-${PV}"