blob: 00cca53b5a626aedb23c3f9e7aae24cc297f4d82 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux Key Management Utilities"
2DESCRIPTION = "\
3 Utilities to control the kernel key management facility and to provide \
4 a mechanism by which the kernel call back to userspace to get a key \
5 instantiated. \
6 "
7HOMEPAGE = "http://people.redhat.com/dhowells/keyutils"
8SECTION = "base"
9
10LICENSE = "LGPLv2.1+ & GPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \
13 file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f"
14
Brad Bishop15ae2502019-06-18 21:44:24 -040015inherit siteinfo autotools-brokensep ptest
Brad Bishop19323692019-04-05 15:28:33 -040016
17SRC_URI = "http://people.redhat.com/dhowells/keyutils/${BP}.tar.bz2 \
18 file://keyutils-test-fix-output-format.patch \
19 file://keyutils-fix-error-report-by-adding-default-message.patch \
20 file://run-ptest \
Brad Bishop15ae2502019-06-18 21:44:24 -040021 file://fix_library_install_path.patch \
Brad Bishop19323692019-04-05 15:28:33 -040022 "
23
Brad Bishop0e2770c2020-01-21 07:31:46 -050024SRC_URI[md5sum] = "919af7f33576816b423d537f8a8692e8"
25SRC_URI[sha256sum] = "c8b15722ae51d95b9ad76cc6d49a4c2cc19b0c60f72f61fb9bf43eea7cbd64ce"
Brad Bishop19323692019-04-05 15:28:33 -040026
27EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \
28 NO_ARLIB=1 \
29 BINDIR=${base_bindir} \
30 SBINDIR=${base_sbindir} \
Brad Bishop15ae2502019-06-18 21:44:24 -040031 LIBDIR=${libdir} \
32 USRLIBDIR=${libdir} \
33 INCLUDEDIR=${includedir} \
Brad Bishop19323692019-04-05 15:28:33 -040034 BUILDFOR=${SITEINFO_BITS}-bit \
35 NO_GLIBC_KEYERR=1 \
36 "
37
38do_install () {
Brad Bishop15ae2502019-06-18 21:44:24 -040039 install -d ${D}/${libdir}/pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040040 oe_runmake DESTDIR=${D} install
41}
42
Patrick Williams213cb262021-08-07 19:21:33 -050043do_install:append:class-nativesdk() {
Brad Bishop779d0ac2019-09-27 08:23:48 -040044 install -d ${D}${datadir}
45 src_dir="${D}${target_datadir}"
46 mv $src_dir/* ${D}${datadir}
47 par_dir=`dirname $src_dir`
48 rmdir $src_dir $par_dir
49
50 install -d ${D}${sysconfdir}
51 mv ${D}/etc/* ${D}${sysconfdir}/
52 rmdir ${D}/etc
53}
54
Brad Bishop19323692019-04-05 15:28:33 -040055do_install_ptest () {
56 cp -r ${S}/tests ${D}${PTEST_PATH}/
57 sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh
58}
59
Brad Bishop19323692019-04-05 15:28:33 -040060
Patrick Williams213cb262021-08-07 19:21:33 -050061RDEPENDS:${PN}-ptest += "lsb-release"
62RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils"
63RDEPENDS:${PN}-ptest:append:libc-musl = " musl-utils"
Brad Bishop15ae2502019-06-18 21:44:24 -040064
65BBCLASSEXTEND = "native nativesdk"