blob: c2e3585f9d753ea3dd96861aef66625fa8f1b60c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
3SECTION = "security"
4LICENSE = "GPL-2.0"
5
Brad Bishop0a921262019-09-24 07:40:45 -04006LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=66938a7e5b4c118eda78271de14874c2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
9 file://nmap-redefine-the-python-library-dir.patch \
10 file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
Brad Bishop0a921262019-09-24 07:40:45 -040011 file://0001-Include-time.h-header-to-pass-clang-compilation.patch \
Andrew Geissler1548c072019-02-22 16:03:50 -060012 file://0002-Fix-building-with-libc.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://0001-Make-ndiff-support-python3.patch \
14 file://0001-configure.ac-make-ndiff-depend-on-python3.patch \
Andrew Geissler1548c072019-02-22 16:03:50 -060015 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
Brad Bishop0a921262019-09-24 07:40:45 -040017SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5"
18SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Andrew Geissler82c905d2020-04-13 13:39:40 -050020inherit autotools-brokensep pkgconfig python3native
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22PACKAGECONFIG ?= "ncat nping ndiff pcap"
23
24PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
Andrew Geissler1548c072019-02-22 16:03:50 -060025PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpcre"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
27PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2"
28PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib"
29
30#disable/enable packages
31PACKAGECONFIG[nping] = ",--without-nping,"
32PACKAGECONFIG[ncat] = ",--without-ncat,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050033PACKAGECONFIG[ndiff] = "--with-ndiff=yes,--without-ndiff,python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034PACKAGECONFIG[update] = ",--without-nmap-update,"
35
36EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
37
38# zenmap needs python-pygtk which has been removed
39# it also only works with python2
40# disable for now until py3 is supported
41EXTRA_OECONF += "--without-zenmap"
42
43export PYTHON_SITEPACKAGES_DIR
44
45do_configure() {
46 autoconf
Brad Bishop19323692019-04-05 15:28:33 -040047 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
48 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049 oe_runconf
50}
51
Patrick Williams213cb262021-08-07 19:21:33 -050052do_install:append() {
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070053 for f in ndiff uninstall_ndiff; do
54 if [ -f ${D}${bindir}/$f ]; then
55 sed -i 's@^#!.*$@#!/usr/bin/env python3@g' ${D}${bindir}/$f
56 fi
57 done
Andrew Geissler82c905d2020-04-13 13:39:40 -050058}
59
Patrick Williams213cb262021-08-07 19:21:33 -050060FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080061
Patrick Williams213cb262021-08-07 19:21:33 -050062RDEPENDS:${PN} += "python3-core"