blob: dbe1647d25351c1412426568ab5676270250775e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "The tpm-tools package contains commands to allow the platform administrator the ability to manage and diagnose the platform's TPM."
2DESCRIPTION = " \
3 The tpm-tools package contains commands to allow the platform administrator \
4 the ability to manage and diagnose the platform's TPM. Additionally, the \
5 package contains commands to utilize some of the capabilities available \
6 in the TPM PKCS#11 interface implemented in the openCryptoki project. \
7 "
8SECTION = "tpm"
9LICENSE = "CPL-1.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=059e8cd6165cb4c31e351f2b69388fd9"
11
Andrew Geissler59125e02021-07-23 12:56:22 -040012DEPENDS = "libtspi openssl perl"
Patrick Williams213cb262021-08-07 19:21:33 -050013DEPENDS:class-native = "trousers-native"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
Andrew Geissler9d3cc052021-03-31 13:36:22 -050015SRCREV = "bf43837575c5f7d31865562dce7778eae970052e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016SRC_URI = " \
Andrew Geissler59125e02021-07-23 12:56:22 -040017 git://git.code.sf.net/p/trousers/tpm-tools \
18 file://tpm-tools-extendpcr.patch \
19 file://04-fix-FTBFS-clang.patch \
20 file://openssl1.1_fix.patch \
21 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022
23inherit autotools-brokensep gettext
24
25S = "${WORKDIR}/git"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027do_configure:prepend () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 mkdir -p po
29 mkdir -p m4
30 cp -R po_/* po/
31 touch po/Makefile.in.in
32 touch m4/Makefile.am
33}
34
35BBCLASSEXTEND = "native"