blob: b11f1539a2da835a52f33dbf5049ada56e2593e3 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060011 file://determinism.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040012 file://no-werror.patch"
13SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10"
14
15S = "${WORKDIR}/git"
16
17inherit pkgconfig
18
19export CCLD_FOR_BUILD = "${BUILD_CCLD}"
20
21# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
22# enforce BFD.
23LDFLAGS += "-fuse-ld=bfd"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025do_compile:prepend() {
Brad Bishop15ae2502019-06-18 21:44:24 -040026 # Remove when https://github.com/rhboot/efivar/issues/130 is fixed
Brad Bishop96ff1982019-08-19 13:50:42 -040027 oe_runmake \
28 CFLAGS="${BUILD_CFLAGS}" \
29 LDFLAGS="${BUILD_LDFLAGS}" \
30 -C src makeguids
Brad Bishop15ae2502019-06-18 21:44:24 -040031}
32
33do_install() {
34 oe_runmake install DESTDIR=${D}
35}
36
37BBCLASSEXTEND = "native"
38
Patrick Williams213cb262021-08-07 19:21:33 -050039RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
Brad Bishop15ae2502019-06-18 21:44:24 -040040
41CLEANBROKEN = "1"