blob: 8a6c297cb0d0c3c79cfadae5dc2b68fbe71edb6b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Enables PPP dial-in through a serial connection"
2SECTION = "console/network"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "PPP dail-in provides a point to point protocol (PPP), so that other computers can dial up to it and access connected networks."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004DEPENDS = "ppp"
Patrick Williams213cb262021-08-07 19:21:33 -05005RDEPENDS:${PN} = "ppp"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006PR = "r8"
7LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10SRC_URI = "file://host-peer \
11 file://ppp-dialin"
12
13inherit allarch useradd
14
15S = "${WORKDIR}"
16
17do_install() {
18 install -d ${D}${sysconfdir}/ppp/peers
19 install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
20
21 install -d ${D}${sbindir}
22 install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
23}
24
25USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050026USERADD_PARAM:${PN} = "--system --home /dev/null \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027 --no-create-home --shell ${sbindir}/ppp-dialin \
28 --no-user-group --gid nogroup ppp"