blob: fd6f17b656a6ff3e8be56545fc96663ad8c3e5ab [file] [log] [blame]
Andrew Geissler90fd73c2021-03-05 15:25:55 -06001SUMMARY = "Boot performance graphing tool"
2DESCRIPTION = "For systemd-bootchart, several proc debug interfaces are required in the kernel config: \
3 CONFIG_SCHEDSTATS \
4below is optional, for additional info: \
5 CONFIG_SCHED_DEBUG"
6HOMEPAGE = "https://github.com/systemd/systemd-bootchart"
Brad Bishop316dfdd2018-06-25 12:45:53 -04007LICENSE = "LGPLv2.1 & GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
9 file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
10
11SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 file://0001-architecture-Recognise-RISCV-32-RISCV-64.patch \
13 file://mips64.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060014 file://no_lto.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040015"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017SRC_URI:append:libc-musl = " \
Brad Bishop316dfdd2018-06-25 12:45:53 -040018 file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
19 file://0002-musl-does-not-provide-printf-h.patch \
20 file://0003-musl-does-not-provide-canonicalize_file_name.patch \
21 "
22
23
Andrew Geisslerd1e89492021-02-12 15:35:20 -060024SRCREV = "8183cfd9dad8beca5434d625cf6b2df87775e956"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025
26S = "${WORKDIR}/git"
27
28DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
29
Brad Bishop6dbb3162019-11-25 09:41:34 -050030inherit pkgconfig autotools systemd features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040031
32REQUIRED_DISTRO_FEATURES = "systemd"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034SYSTEMD_SERVICE:${PN} = "systemd-bootchart.service"
Brad Bishop316dfdd2018-06-25 12:45:53 -040035
Patrick Williams213cb262021-08-07 19:21:33 -050036do_configure:prepend() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040037 # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
38 rm -f ${S}/m4/intltool.m4
39}
40
Patrick Williams213cb262021-08-07 19:21:33 -050041FILES:${PN} += "${systemd_unitdir}/systemd-bootchart"
Brad Bishop316dfdd2018-06-25 12:45:53 -040042
Brad Bishop79641f22019-09-10 07:20:22 -040043EXTRA_OECONF = " --with-rootprefix=${root_prefix} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040044 --with-rootlibdir=${base_libdir}"