blob: c096a8c9a88f1bc781eb6167217b919686b0aa93 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
Andrew Geisslerd1e89492021-02-12 15:35:20 -06009SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2"
Brad Bishopc342db32019-05-15 21:57:59 -040010
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060011SRC_URI[sha256sum] = "b44cc67f8a1f6b0250b7c860e952b37e8ed932a90bd9b1862a511079255646ff"
Brad Bishopc342db32019-05-15 21:57:59 -040012
13inherit autotools gettext texinfo
14
15PACKAGECONFIG ??= ""
Patrick Williams213cb262021-08-07 19:21:33 -050016PACKAGECONFIG:append:class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
Brad Bishopc342db32019-05-15 21:57:59 -040017
18PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
19
20EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
21
Andrew Geissler82c905d2020-04-13 13:39:40 -050022CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no"
23
Brad Bishopc342db32019-05-15 21:57:59 -040024# Let aclocal use the relative path for the m4 file rather than the
25# absolute since tar has a lot of m4 files, otherwise there might
26# be an "Argument list too long" error when it is built in a long/deep
27# directory.
28acpaths = "-I ./m4"
29
30do_install () {
31 autotools_do_install
32 ln -s tar ${D}${bindir}/gtar
33}
34
Patrick Williams213cb262021-08-07 19:21:33 -050035do_install:append:class-target() {
Brad Bishopc342db32019-05-15 21:57:59 -040036 if [ "${base_bindir}" != "${bindir}" ]; then
37 install -d ${D}${base_bindir}
38 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
39 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
40 rmdir ${D}${bindir}/
41 fi
42}
43
44PACKAGES =+ "${PN}-rmt"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046FILES:${PN}-rmt = "${sbindir}/rmt*"
Brad Bishopc342db32019-05-15 21:57:59 -040047
48inherit update-alternatives
49
50ALTERNATIVE_PRIORITY = "100"
51
Patrick Williams213cb262021-08-07 19:21:33 -050052ALTERNATIVE:${PN} = "tar"
53ALTERNATIVE:${PN}-rmt = "rmt"
54ALTERNATIVE:${PN}:class-nativesdk = ""
55ALTERNATIVE:${PN}-rmt:class-nativesdk = ""
Brad Bishopc342db32019-05-15 21:57:59 -040056
57ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
58ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
59
Patrick Williams213cb262021-08-07 19:21:33 -050060PROVIDES:append:class-native = " tar-replacement-native"
Brad Bishopc342db32019-05-15 21:57:59 -040061NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
62
63BBCLASSEXTEND = "native nativesdk"