Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 1 | SUMMARY = "Socket-based service activation daemon" |
| 2 | HOMEPAGE = "https://github.com/xinetd-org/xinetd" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things." |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 4 | |
| 5 | # xinetd is a BSD-like license |
| 6 | # Apple and Gentoo say BSD here. |
| 7 | LICENSE = "BSD" |
| 8 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f" |
| 9 | |
| 10 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
| 11 | |
| 12 | SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \ |
| 13 | file://xinetd.init \ |
| 14 | file://xinetd.default \ |
| 15 | file://xinetd.service \ |
| 16 | " |
| 17 | |
| 18 | SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 22 | # https://github.com/xinetd-org/xinetd/pull/10 is merged into this git tree revision |
| 23 | CVE_CHECK_WHITELIST += "CVE-2013-4342" |
| 24 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 25 | inherit autotools update-rc.d systemd pkgconfig |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 27 | SYSTEMD_SERVICE:${PN} = "xinetd.service" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 28 | |
| 29 | INITSCRIPT_NAME = "xinetd" |
| 30 | INITSCRIPT_PARAMS = "defaults" |
| 31 | |
| 32 | PACKAGECONFIG ??= "tcp-wrappers" |
| 33 | PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers" |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 35 | CONFFILES:${PN} = "${sysconfdir}/xinetd.conf" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 37 | do_install:append() { |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 38 | install -d "${D}${sysconfdir}/init.d" |
| 39 | install -d "${D}${sysconfdir}/default" |
| 40 | install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd" |
| 41 | install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd" |
| 42 | |
| 43 | # Install systemd unit files |
| 44 | install -d ${D}${systemd_unitdir}/system |
| 45 | install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system |
| 46 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 47 | -e 's,@SBINDIR@,${sbindir},g' \ |
| 48 | ${D}${systemd_unitdir}/system/xinetd.service |
| 49 | } |
| 50 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 51 | RDEPENDS:${PN} += "perl" |