blob: e6ef5cf8b9a7df2fb05d349cc8fa3772af7289f9 [file] [log] [blame]
Andrew Geissler5a43b432020-06-13 10:46:56 -05001SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things."
Andrew Geissler5a43b432020-06-13 10:46:56 -05004
5# xinetd is a BSD-like license
6# Apple and Gentoo say BSD here.
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
9
10UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
11
12SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \
13 file://xinetd.init \
14 file://xinetd.default \
15 file://xinetd.service \
16 "
17
18SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
19
20S = "${WORKDIR}/git"
21
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022# https://github.com/xinetd-org/xinetd/pull/10 is merged into this git tree revision
23CVE_CHECK_WHITELIST += "CVE-2013-4342"
24
Andrew Geissler5a43b432020-06-13 10:46:56 -050025inherit autotools update-rc.d systemd pkgconfig
26
Patrick Williams213cb262021-08-07 19:21:33 -050027SYSTEMD_SERVICE:${PN} = "xinetd.service"
Andrew Geissler5a43b432020-06-13 10:46:56 -050028
29INITSCRIPT_NAME = "xinetd"
30INITSCRIPT_PARAMS = "defaults"
31
32PACKAGECONFIG ??= "tcp-wrappers"
33PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035CONFFILES:${PN} = "${sysconfdir}/xinetd.conf"
Andrew Geissler5a43b432020-06-13 10:46:56 -050036
Patrick Williams213cb262021-08-07 19:21:33 -050037do_install:append() {
Andrew Geissler5a43b432020-06-13 10:46:56 -050038 install -d "${D}${sysconfdir}/init.d"
39 install -d "${D}${sysconfdir}/default"
40 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
41 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
42
43 # Install systemd unit files
44 install -d ${D}${systemd_unitdir}/system
45 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system
46 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
47 -e 's,@SBINDIR@,${sbindir},g' \
48 ${D}${systemd_unitdir}/system/xinetd.service
49}
50
Patrick Williams213cb262021-08-07 19:21:33 -050051RDEPENDS:${PN} += "perl"