blob: 6852758c6a9c3dd42ab052c2049f047e9f55634d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Brad Bishop6dbb3162019-11-25 09:41:34 -050012 "
Andrew Geisslerc926e172021-05-07 16:11:35 -050013SRC_URI[sha256sum] = "0e46e5acb087ce7d1ac53cf4f56a09b221537fc86dfc5daaad1c2e89e1b37ac8"
Brad Bishop19323692019-04-05 15:28:33 -040014
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
William A. Kennington IIIac69b482021-06-02 12:28:27 -070018# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
19# and 4.3.0 doesn't have the issue
20CVE_CHECK_WHITELIST += "CVE-2015-7313"
21
Brad Bishop19323692019-04-05 15:28:33 -040022inherit autotools multilib_header
23
24CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
25
26PACKAGECONFIG ?= "cxx jpeg zlib lzma \
27 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
28
29PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
30PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
31PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
32PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
33
34# Convert single-strip uncompressed images to multiple strips of specified
35# size (default: 8192) to reduce memory usage
36PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
37
38# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
39PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
40
41# Control picking up YCbCr subsample info. Disable to support files lacking
42# the tag
43PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
44
45# Support a mechanism allowing reading large strips (usually one strip files)
46# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
47PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
48
49PACKAGES =+ "tiffxx tiff-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050050FILES:tiffxx = "${libdir}/libtiffxx.so.*"
51FILES:tiff-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040052
Patrick Williams213cb262021-08-07 19:21:33 -050053do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040054 oe_multilib_header tiffconf.h
55}
56
Andrew Geissler4ed12e12020-06-05 18:00:41 -050057BBCLASSEXTEND = "native nativesdk"