blob: 9f961882af0b09d39f079f401371de776c7db387 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "A text-based user interface plugin of dnf for user to manage packages. "
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Brad Bishop26bdd442019-08-16 17:08:17 -04003
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
Andrew Geissler595f6302022-01-24 19:11:47 +00006SRC_URI = "git://github.com/ubinux/dnf-plugin-tui.git;branch=master;protocol=https"
Patrick Williams2194f502022-10-16 14:26:09 -05007SRCREV = "b0d80b7129f1d84cc563a4098d869e7420bcf4bc"
William A. Kennington III49e95662021-09-15 16:19:36 -07008PV = "1.3"
Brad Bishop26bdd442019-08-16 17:08:17 -04009
Patrick Williams213cb262021-08-07 19:21:33 -050010SRC_URI:append:class-target = " file://oe-remote.repo.sample"
Brad Bishop26bdd442019-08-16 17:08:17 -040011
Andrew Geissler595f6302022-01-24 19:11:47 +000012inherit setuptools3-base
Brad Bishop26bdd442019-08-16 17:08:17 -040013
14S = "${WORKDIR}/git"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016do_install:append() {
Brad Bishop90ca7472019-08-20 09:15:15 -040017 install -d ${D}${datadir}/dnf
18 install -m 0755 ${S}/samples/* ${D}${datadir}/dnf
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
20 install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
21 for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do
22 install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins
23 done
Brad Bishop26bdd442019-08-16 17:08:17 -040024}
25
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:append:class-target() {
Brad Bishop90ca7472019-08-20 09:15:15 -040027 install -d ${D}${sysconfdir}/yum.repos.d
28 install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d
Brad Bishop26bdd442019-08-16 17:08:17 -040029}
30
Patrick Williams92b42cb2022-09-03 06:53:57 -050031do_install:append:class-nativesdk() {
32 install -d -p ${D}/${SDKPATH}/postinst-intercepts
33 cp -r ${COREBASE}/scripts/postinst-intercepts/* ${D}/${SDKPATH}/postinst-intercepts/
34 sed -i -e 's/STAGING_DIR_NATIVE/NATIVE_ROOT/g' ${D}/${SDKPATH}/postinst-intercepts/*
35}
36
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN} += "${datadir}/dnf"
Patrick Williams92b42cb2022-09-03 06:53:57 -050038FILES:${PN} += "${SDKPATH}/postinst-intercepts"
Brad Bishop26bdd442019-08-16 17:08:17 -040039
Patrick Williams213cb262021-08-07 19:21:33 -050040RDEPENDS:${PN} += " \
Brad Bishop90ca7472019-08-20 09:15:15 -040041 bash \
42 dnf \
43 libnewt-python \
44"
Patrick Williams2194f502022-10-16 14:26:09 -050045DEPENDS:append:class-nativesdk = " file-replacement-nativesdk"
Brad Bishop26bdd442019-08-16 17:08:17 -040046BBCLASSEXTEND = "nativesdk"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000047SKIP_RECIPE[dnf-plugin-tui] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build correctly without package_rpm in PACKAGE_CLASSES', d)}"