blob: acbf80a685bc8e2f0fb890f7c62f8388147818c6 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
Brad Bishop220d5532018-08-14 00:59:39 +01005HOMEPAGE = "https://sourceware.org/bzip2/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006SECTION = "console/utils"
7LICENSE = "bzip2"
8LIC_FILES_CHKSUM = "file://LICENSE;beginline=8;endline=37;md5=40d9d1eb05736d1bfc86cfdd9106e6b2"
9PR = "r5"
10
Brad Bishop220d5532018-08-14 00:59:39 +010011SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/${BP}.tar.gz \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050012 file://fix-bunzip2-qt-returns-0-for-corrupt-archives.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://configure.ac;subdir=${BP} \
14 file://Makefile.am;subdir=${BP} \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015 file://run-ptest \
16 file://CVE-2016-3189.patch \
17 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
20SRC_URI[sha256sum] = "a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd"
21
Brad Bishop220d5532018-08-14 00:59:39 +010022UPSTREAM_CHECK_URI = "https://www.sourceware.org/bzip2/"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050023
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024PACKAGES =+ "libbz2"
25
26CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
27
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028inherit autotools update-alternatives ptest relative_symlinks
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029
30ALTERNATIVE_PRIORITY = "100"
31ALTERNATIVE_${PN} = "bunzip2 bzcat"
32
33#install binaries to bzip2-native under sysroot for replacement-native
34EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
35
36do_install_ptest () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
38}
39
40FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
41
42PROVIDES_append_class-native = " bzip2-replacement-native"
43BBCLASSEXTEND = "native nativesdk"
44