blob: d6ca242c5831bea770d7e7007df67f963cf4d785 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "JSON Web Token implementation in Python"
2DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
3 Original implementation was written by https://github.com/progrium"
4HOMEPAGE = "http://github.com/jpadilla/pyjwt"
5LICENSE = "MIT"
Andrew Geissler78b72792022-06-14 06:47:25 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551"
Andrew Geisslereff27472021-10-29 15:35:00 -05007
Patrick Williams2390b1b2022-11-03 13:47:49 -05008SRC_URI[sha256sum] = "69285c7e31fc44f68a1feb309e948e0df53259d579295e6cfe2b1792329f05fd"
Andrew Geisslereff27472021-10-29 15:35:00 -05009
10PYPI_PACKAGE = "PyJWT"
11inherit pypi setuptools3
12
13RDEPENDS:${PN} = "${PYTHON_PN}-cryptography"
14
15BBCLASSEXTEND = "native nativesdk"