blob: ef5af3a57d4aac92b5ba020381d8044659eb93b6 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection bash-completion
11
Brad Bishop26bdd442019-08-16 17:08:17 -040012DEPENDS = "glib-2.0 libgudev intltool-native libxslt-native"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
15 "
Brad Bishop15ae2502019-06-18 21:44:24 -040016SRC_URI[md5sum] = "92d25176d0cc9d588ca29700b33c7d98"
17SRC_URI[sha256sum] = "fd0f39996025dac96995daea8a58ec7dd571582f7563a8ae0d5f65b571b76ee2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19S = "${WORKDIR}/ModemManager-${PV}"
20
Brad Bishop19323692019-04-05 15:28:33 -040021PACKAGECONFIG ??= "mbim qmi \
22 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023"
24
25PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
26PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
27# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
Brad Bishop19323692019-04-05 15:28:33 -040028PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
30PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
31
32EXTRA_OECONF = " \
33 --with-udev-base-dir=${nonarch_base_libdir}/udev \
34"
Brad Bishop26bdd442019-08-16 17:08:17 -040035EXTRA_OECONF_append_toolchain-clang = " --enable-more-warnings=no"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036
37FILES_${PN} += " \
38 ${datadir}/icons \
39 ${datadir}/polkit-1 \
40 ${datadir}/dbus-1 \
41 ${libdir}/ModemManager \
42 ${systemd_unitdir}/system \
43"
44
45FILES_${PN}-dev += " \
46 ${libdir}/ModemManager/*.la \
47"
48
49FILES_${PN}-staticdev += " \
50 ${libdir}/ModemManager/*.a \
51"
52
53FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
54
55SYSTEMD_SERVICE_${PN} = "ModemManager.service"