blob: ffa2c49ee932676aa548ef9c8641b2823a5d5d28 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
4
Brad Bishop26bdd442019-08-16 17:08:17 -04005DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007SRC_URI = " \
8 http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
9 file://0001-linux-lower-severity-of-unhandled-action-messages.patch \
10"
Brad Bishop316dfdd2018-06-25 12:45:53 -040011SRC_URI[md5sum] = "236bb439d9ff1151450b3d8582399532"
12SRC_URI[sha256sum] = "24bcc2f6ab25a2533bac70b587bcb019e591293076920f5b5e04bdedc140a401"
13
Brad Bishop19323692019-04-05 15:28:33 -040014inherit autotools pkgconfig gettext gobject-introspection systemd distro_features_check
15
Brad Bishop316dfdd2018-06-25 12:45:53 -040016PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
17PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
18PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
19 --without-systemdutildir --without-systemdsystemunitdir,systemd"
20
21EXTRA_OECONF = " --with-backend=linux"
22
23SYSTEMD_SERVICE_${PN} = "upower.service"
24# don't start on boot by default - dbus does that on demand
25SYSTEMD_AUTO_ENABLE = "disable"
26
27do_configure_prepend() {
28 sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
29 sed -i -e 's: doc : :g' ${S}/Makefile.am
30}
31
32RDEPENDS_${PN} += "dbus"
33RRECOMMENDS_${PN} += "pm-utils"
34FILES_${PN} += "${datadir}/dbus-1/ \
Brad Bishop316dfdd2018-06-25 12:45:53 -040035 ${base_libdir}/udev/* \
36"