Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "A library on top of GStreamer for building an RTSP server" |
| 2 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-rtsp-server/" |
| 3 | SECTION = "multimedia" |
| 4 | LICENSE = "LGPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d" |
| 6 | |
| 7 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base" |
| 8 | |
| 9 | PNREAL = "gst-rtsp-server" |
| 10 | |
| 11 | SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ |
| 13 | file://gtk-doc-tweaks.patch \ |
| 14 | " |
| 15 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 16 | SRC_URI[md5sum] = "adc4460239ec2eccf58ad9752ce53bfd" |
| 17 | SRC_URI[sha256sum] = "198e9eec1a3e32dc810d3fbf3a714850a22c6288d4a5c8e802c5ff984af03f19" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 20 | |
| 21 | inherit autotools pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 22 | |
| 23 | EXTRA_OECONF = "--disable-examples --disable-tests" |
| 24 | |
| 25 | # Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well |
| 26 | LIBV = "1.0" |
| 27 | require gst-plugins-package.inc |
| 28 | |
| 29 | delete_pkg_m4_file() { |
| 30 | # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection |
| 31 | rm "${S}/common/m4/pkg.m4" || true |
| 32 | } |
| 33 | |
| 34 | do_configure[prefuncs] += " delete_pkg_m4_file" |