blob: b28711eb0ec3172ac9817ee84c5d1fc38f513b94 [file] [log] [blame]
Potin Laie096c412022-09-01 14:12:25 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
4inherit obmc-phosphor-systemd
5
6RDEPENDS:${PN} += " bash motor-ctrl"
Potin Lai83c294d2022-10-17 16:24:32 +08007RDEPENDS:${PN} += " mdio-tools"
Potin Laie096c412022-09-01 14:12:25 +08008
9SRC_URI += " \
10 file://bletchley-system-state-init \
11 file://bletchley-system-state-init@.service \
Potin Lai83c294d2022-10-17 16:24:32 +080012 file://bletchley-switch-diag \
Potin Lai291d1382023-01-03 09:31:22 +080013 file://bletchley-usbmux-util \
Potin Laie096c412022-09-01 14:12:25 +080014 "
15
16do_install() {
17 install -d ${D}${libexecdir}
18 install -m 0755 ${WORKDIR}/bletchley-system-state-init ${D}${libexecdir}
Potin Lai83c294d2022-10-17 16:24:32 +080019 install -m 0755 ${WORKDIR}/bletchley-switch-diag ${D}${libexecdir}
Potin Lai291d1382023-01-03 09:31:22 +080020
21 install -d ${D}${bindir}
22 install -m 0755 ${WORKDIR}/bletchley-usbmux-util ${D}${bindir}
Potin Laie096c412022-09-01 14:12:25 +080023}
24
25
26TGT = "${SYSTEMD_DEFAULT_TARGET}"
27BLETCHLEY_SYS_ST_INIT_INSTFMT="../bletchley-system-state-init@.service:${TGT}.wants/bletchley-system-state-init@{0}.service"
28
29SYSTEMD_SERVICE:${PN} += "bletchley-system-state-init@.service"
30SYSTEMD_LINK:${PN} += "${@compose_list(d, 'BLETCHLEY_SYS_ST_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}"