blob: dc519669010a714599167f5d436314ac86dd4caa [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
Andrew Geissler748a4832020-07-24 16:24:21 -05004LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005
6inherit pypi setuptools3 ptest
7
Andrew Geisslerac970dd2021-02-12 15:32:45 -06008SRC_URI[md5sum] = "8c849bdf95414fe708a84473e42d4406"
9SRC_URI[sha256sum] = "83a4a90894bf38e243cf052c8b58f381bfe9a7a483f6a9cab140bc7f702ac4da"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Patrick Williams213cb262021-08-07 19:21:33 -050011RDEPENDS:${PN}:class-target += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-doctest \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-pickle \
16 ${PYTHON_PN}-pprint \
17 ${PYTHON_PN}-threading \
18"
19
20BBCLASSEXTEND = "native nativesdk"
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 ${PYTHON_PN}-pytest \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
Andrew Geissler748a4832020-07-24 16:24:21 -050034 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
Andrew Geissler82c905d2020-04-13 13:39:40 -050035
36}