blob: 7bab771f7f9372ba1b7bdb9078eed633db7f2fe1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
5
Andrew Geissler4b7c1152020-11-30 19:55:29 -06006SRC_URI[sha256sum] = "8a9066529240171b68893d60dca86a763eae2139dd42f42106b03cf4b426bf10"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI += " \
9 file://run-ptest \
Andrew Geissler69721092021-07-23 12:57:00 -040010 file://0001-Drop-tests-for-semicolon-as-a-separator.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011"
12
13PYPI_PACKAGE = "yarl"
14
15inherit pypi ptest setuptools3
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050018 ${PYTHON_PN}-multidict \
19 ${PYTHON_PN}-idna \
20"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}