blob: 2ff9c2b11223af05e6563ca39e801bb2b5228e19 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
Patrick Williams213cb262021-08-07 19:21:33 -05008SUMMARY:${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION:${PN}-dev = "This package contains the RPM C library and header files. These \
Brad Bishop19323692019-04-05 15:28:33 -040010development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
Patrick Williams213cb262021-08-07 19:21:33 -050016SUMMARY:python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION:python3-rpm = "The python3-rpm package contains a module that permits applications \
Brad Bishop19323692019-04-05 15:28:33 -040018written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060025LIC_FILES_CHKSUM = "file://COPYING;md5=c4eec0c20c6034b9407a09945b48a43f"
Brad Bishop19323692019-04-05 15:28:33 -040026
Andrew Geissler6ce62a22020-11-30 19:58:47 -060027SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.16.x \
Andrew Geissler635e0e42020-08-21 15:58:33 -050028 file://environment.d-rpm.sh \
Brad Bishop19323692019-04-05 15:28:33 -040029 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
30 file://0001-Do-not-read-config-files-from-HOME.patch \
31 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
32 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
33 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
34 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
35 file://0001-Fix-build-with-musl-C-library.patch \
36 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
37 file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
Brad Bishop19323692019-04-05 15:28:33 -040038 file://0001-perl-disable-auto-reqs.patch \
39 file://0001-rpm-rpmio.c-restrict-virtual-memory-usage-if-limit-s.patch \
40 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050041 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060042 file://0001-tools-Add-error.h-for-non-glibc-case.patch \
Patrick Williams93c203f2021-10-06 16:15:23 -050043 file://0001-build-pack.c-do-not-insert-payloadflags-into-.rpm-me.patch \
Brad Bishop19323692019-04-05 15:28:33 -040044 "
45
46PE = "1"
Andrew Geisslerc926e172021-05-07 16:11:35 -050047SRCREV = "3659b8a04f5b8bacf6535e0124e7fe23f15286bd"
Brad Bishop19323692019-04-05 15:28:33 -040048
49S = "${WORKDIR}/git"
50
William A. Kennington IIIac69b482021-06-02 12:28:27 -070051DEPENDS = "libgcrypt file popt xz bzip2 elfutils python3"
Patrick Williams213cb262021-08-07 19:21:33 -050052DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
Brad Bishop19323692019-04-05 15:28:33 -040053
54inherit autotools gettext pkgconfig python3native
55export PYTHON_ABI
56
Andrew Geissler6ce62a22020-11-30 19:58:47 -060057AUTOTOOLS_AUXDIR = "${S}/build-aux"
58
Brad Bishop19323692019-04-05 15:28:33 -040059# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
Patrick Williams213cb262021-08-07 19:21:33 -050060EXTRA_AUTORECONF:append = " --exclude=gnu-configize"
Brad Bishop19323692019-04-05 15:28:33 -040061
Patrick Williams213cb262021-08-07 19:21:33 -050062EXTRA_OECONF:append = " --without-lua --enable-python --with-crypto=libgcrypt"
63EXTRA_OECONF:append:libc-musl = " --disable-nls --disable-openmp"
Brad Bishop19323692019-04-05 15:28:33 -040064
65# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
Brad Bishop19323692019-04-05 15:28:33 -040066# --localstatedir prevents rpm from writing its database to native sysroot when building images
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050067# Forcibly disable plugins for native/nativesdk, as the inhibit and prioreset
68# plugins both behave badly inside builds.
Patrick Williams213cb262021-08-07 19:21:33 -050069EXTRA_OECONF:append:class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
70EXTRA_OECONF:append:class-nativesdk = " --sysconfdir=/etc --disable-plugins"
Brad Bishop19323692019-04-05 15:28:33 -040071
72BBCLASSEXTEND = "native nativesdk"
73
William A. Kennington IIIac69b482021-06-02 12:28:27 -070074PACKAGECONFIG ??= "bdb ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)}"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050075# The inhibit plugin serves no purpose outside of the target
Patrick Williams213cb262021-08-07 19:21:33 -050076PACKAGECONFIG:remove:class-native = "inhibit"
77PACKAGECONFIG:remove:class-nativesdk = "inhibit"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050078
William A. Kennington IIIac69b482021-06-02 12:28:27 -070079PACKAGECONFIG[bdb] = "--enable-bdb,--disable-bdb,db"
Brad Bishop19323692019-04-05 15:28:33 -040080PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050081PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
82PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"
Brad Bishop19323692019-04-05 15:28:33 -040083
84ASNEEDED = ""
85
86# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
87# libmagic also has sysroot path contamination, so override it
88
89WRAPPER_TOOLS = " \
90 ${bindir}/rpm \
91 ${bindir}/rpm2archive \
92 ${bindir}/rpm2cpio \
93 ${bindir}/rpmbuild \
94 ${bindir}/rpmdb \
95 ${bindir}/rpmgraph \
96 ${bindir}/rpmkeys \
97 ${bindir}/rpmsign \
98 ${bindir}/rpmspec \
99 ${libdir}/rpm/rpmdeps \
100"
101
Patrick Williams213cb262021-08-07 19:21:33 -0500102do_configure:prepend() {
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600103 mkdir -p ${S}/build-aux
104}
105
Patrick Williams213cb262021-08-07 19:21:33 -0500106do_install:append:class-native() {
Brad Bishop19323692019-04-05 15:28:33 -0400107 for tool in ${WRAPPER_TOOLS}; do
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500108 test -x ${D}$tool && create_wrapper ${D}$tool \
Brad Bishop19323692019-04-05 15:28:33 -0400109 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
110 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
111 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
112 RPM_NO_CHROOT_FOR_SCRIPTS=1
113 done
114}
115
Patrick Williams213cb262021-08-07 19:21:33 -0500116do_install:append:class-nativesdk() {
Brad Bishop19323692019-04-05 15:28:33 -0400117 for tool in ${WRAPPER_TOOLS}; do
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500118 test -x ${D}$tool && create_wrapper ${D}$tool \
Brad Bishop19323692019-04-05 15:28:33 -0400119 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
120 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
121 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
122 RPM_NO_CHROOT_FOR_SCRIPTS=1
123 done
124
125 rm -rf ${D}/var
Andrew Geissler635e0e42020-08-21 15:58:33 -0500126
127 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
128 install -m 644 ${WORKDIR}/environment.d-rpm.sh ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
Brad Bishop19323692019-04-05 15:28:33 -0400129}
130
131# Rpm's make install creates var/tmp which clashes with base-files packaging
Patrick Williams213cb262021-08-07 19:21:33 -0500132do_install:append:class-target() {
Brad Bishop19323692019-04-05 15:28:33 -0400133 rm -rf ${D}/var
134}
135
Patrick Williams213cb262021-08-07 19:21:33 -0500136do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -0400137 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
138 ${D}/${libdir}/rpm/macros
139
140 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
Andrew Geissler4b740dc2020-05-05 08:54:39 -0500141 ${D}${libdir}/rpm/pythondistdeps.py
Brad Bishop19323692019-04-05 15:28:33 -0400142}
143
Patrick Williams213cb262021-08-07 19:21:33 -0500144FILES:${PN} += "${libdir}/rpm-plugins/*.so \
Brad Bishop19323692019-04-05 15:28:33 -0400145 "
Patrick Williams213cb262021-08-07 19:21:33 -0500146FILES:${PN}:append:class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/rpm.sh"
Brad Bishop19323692019-04-05 15:28:33 -0400147
Patrick Williams213cb262021-08-07 19:21:33 -0500148FILES:${PN}-dev += "${libdir}/rpm-plugins/*.la \
Brad Bishop19323692019-04-05 15:28:33 -0400149 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500150PACKAGE_BEFORE_PN += "${PN}-build ${PN}-sign ${PN}-archive"
151
Patrick Williams213cb262021-08-07 19:21:33 -0500152RRECOMMENDS:${PN} += "rpm-sign rpm-archive"
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500153
Patrick Williams213cb262021-08-07 19:21:33 -0500154FILES:${PN}-build = "\
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500155 ${bindir}/rpmbuild \
156 ${bindir}/gendiff \
157 ${bindir}/rpmspec \
158 ${libdir}/librpmbuild.so.* \
159 ${libdir}/rpm/brp-* \
160 ${libdir}/rpm/check-* \
161 ${libdir}/rpm/debugedit \
162 ${libdir}/rpm/sepdebugcrcfix \
163 ${libdir}/rpm/find-debuginfo.sh \
164 ${libdir}/rpm/find-lang.sh \
165 ${libdir}/rpm/*provides* \
166 ${libdir}/rpm/*requires* \
167 ${libdir}/rpm/*deps* \
168 ${libdir}/rpm/*.prov \
169 ${libdir}/rpm/*.req \
170 ${libdir}/rpm/config.* \
171 ${libdir}/rpm/mkinstalldirs \
172 ${libdir}/rpm/macros.p* \
173 ${libdir}/rpm/fileattrs/* \
174"
175
Patrick Williams213cb262021-08-07 19:21:33 -0500176FILES:${PN}-sign = "\
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500177 ${bindir}/rpmsign \
178 ${libdir}/librpmsign.so.* \
179"
180
Patrick Williams213cb262021-08-07 19:21:33 -0500181FILES:${PN}-archive = "\
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500182 ${bindir}/rpm2archive \
183"
Brad Bishop19323692019-04-05 15:28:33 -0400184
185PACKAGES += "python3-rpm"
186PROVIDES += "python3-rpm"
Patrick Williams213cb262021-08-07 19:21:33 -0500187FILES:python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
Brad Bishop19323692019-04-05 15:28:33 -0400188
Patrick Williams213cb262021-08-07 19:21:33 -0500189RDEPENDS:${PN}-build = "bash perl python3-core"
Brad Bishop19323692019-04-05 15:28:33 -0400190
191PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
192
193# Do not specify a sysroot when compiling on a target.
194rpm_package_preprocess () {
195 sed -i -e 's:--sysroot[^ ]*::g' \
196 ${PKGD}/${libdir}/rpm/macros
197}
Patrick Williams93c203f2021-10-06 16:15:23 -0500198
199SSTATE_HASHEQUIV_FILEMAP = " \
200 populate_sysroot:*/rpm/macros:${TMPDIR} \
201 populate_sysroot:*/rpm/macros:${COREBASE} \
202 "