blob: a1c52055540cb9f3aa0d8b5bcdd93ef71419602f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c0bf017c0fd1920e6158a333acabfd4a"
26
Andrew Geissler4b740dc2020-05-05 08:54:39 -050027SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.15.x \
Andrew Geissler635e0e42020-08-21 15:58:33 -050028 file://environment.d-rpm.sh \
Brad Bishop19323692019-04-05 15:28:33 -040029 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
30 file://0001-Do-not-read-config-files-from-HOME.patch \
31 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
32 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
33 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
34 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
35 file://0001-Fix-build-with-musl-C-library.patch \
36 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
37 file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
Brad Bishop19323692019-04-05 15:28:33 -040038 file://0001-perl-disable-auto-reqs.patch \
39 file://0001-rpm-rpmio.c-restrict-virtual-memory-usage-if-limit-s.patch \
40 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050042 file://0001-rpmfc.c-do-not-run-file-classification-in-parallel.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050043 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050044 file://0001-Bump-up-the-limit-of-signature-header-to-64MB.patch \
Brad Bishop19323692019-04-05 15:28:33 -040045 "
46
47PE = "1"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050048SRCREV = "ab2179452c5be276a6b96c591afded485c7e58c3"
Brad Bishop19323692019-04-05 15:28:33 -040049
50S = "${WORKDIR}/git"
51
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050052DEPENDS = "openssl db file popt xz bzip2 elfutils python3"
Brad Bishop19323692019-04-05 15:28:33 -040053DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
54
55inherit autotools gettext pkgconfig python3native
56export PYTHON_ABI
57
58# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
59EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
60
Andrew Geissler82c905d2020-04-13 13:39:40 -050061EXTRA_OECONF_append = " --without-lua --enable-python --with-crypto=openssl"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050062EXTRA_OECONF_append_libc-musl = " --disable-nls --disable-openmp"
Brad Bishop19323692019-04-05 15:28:33 -040063
64# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
Brad Bishop19323692019-04-05 15:28:33 -040065# --localstatedir prevents rpm from writing its database to native sysroot when building images
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050066# Forcibly disable plugins for native/nativesdk, as the inhibit and prioreset
67# plugins both behave badly inside builds.
Brad Bishop19323692019-04-05 15:28:33 -040068EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050069EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --disable-plugins"
Brad Bishop19323692019-04-05 15:28:33 -040070
71BBCLASSEXTEND = "native nativesdk"
72
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050073PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)}"
74# The inhibit plugin serves no purpose outside of the target
75PACKAGECONFIG_remove_class-native = "inhibit"
76PACKAGECONFIG_remove_class-nativesdk = "inhibit"
77
Brad Bishop19323692019-04-05 15:28:33 -040078PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050079PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
80PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"
Brad Bishop19323692019-04-05 15:28:33 -040081
82ASNEEDED = ""
83
84# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
85# libmagic also has sysroot path contamination, so override it
86
87WRAPPER_TOOLS = " \
88 ${bindir}/rpm \
89 ${bindir}/rpm2archive \
90 ${bindir}/rpm2cpio \
91 ${bindir}/rpmbuild \
92 ${bindir}/rpmdb \
93 ${bindir}/rpmgraph \
94 ${bindir}/rpmkeys \
95 ${bindir}/rpmsign \
96 ${bindir}/rpmspec \
97 ${libdir}/rpm/rpmdeps \
98"
99
100do_install_append_class-native() {
101 for tool in ${WRAPPER_TOOLS}; do
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500102 test -x ${D}$tool && create_wrapper ${D}$tool \
Brad Bishop19323692019-04-05 15:28:33 -0400103 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
104 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
105 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
106 RPM_NO_CHROOT_FOR_SCRIPTS=1
107 done
108}
109
110do_install_append_class-nativesdk() {
111 for tool in ${WRAPPER_TOOLS}; do
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500112 test -x ${D}$tool && create_wrapper ${D}$tool \
Brad Bishop19323692019-04-05 15:28:33 -0400113 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
114 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
115 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
116 RPM_NO_CHROOT_FOR_SCRIPTS=1
117 done
118
119 rm -rf ${D}/var
Andrew Geissler635e0e42020-08-21 15:58:33 -0500120
121 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
122 install -m 644 ${WORKDIR}/environment.d-rpm.sh ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
Brad Bishop19323692019-04-05 15:28:33 -0400123}
124
125# Rpm's make install creates var/tmp which clashes with base-files packaging
126do_install_append_class-target() {
127 rm -rf ${D}/var
128}
129
130do_install_append () {
131 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
132 ${D}/${libdir}/rpm/macros
133
134 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
Andrew Geissler4b740dc2020-05-05 08:54:39 -0500135 ${D}${libdir}/rpm/pythondistdeps.py
Brad Bishop19323692019-04-05 15:28:33 -0400136}
137
138FILES_${PN} += "${libdir}/rpm-plugins/*.so \
139 "
Andrew Geissler635e0e42020-08-21 15:58:33 -0500140FILES_${PN}_append_class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/rpm.sh"
Brad Bishop19323692019-04-05 15:28:33 -0400141
142FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \
143 "
144
145PACKAGES += "python3-rpm"
146PROVIDES += "python3-rpm"
147FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
148
149# rpm 5.x was packaging the rpm build tools separately
150RPROVIDES_${PN} += "rpm-build"
151
152RDEPENDS_${PN} = "bash perl python3-core"
153
154PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
155
156# Do not specify a sysroot when compiling on a target.
157rpm_package_preprocess () {
158 sed -i -e 's:--sysroot[^ ]*::g' \
159 ${PKGD}/${libdir}/rpm/macros
160}