blob: b5a0ac93820cde205fc0fd05f01b5a34acc70da0 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c0bf017c0fd1920e6158a333acabfd4a"
26
Andrew Geissler4b740dc2020-05-05 08:54:39 -050027SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.15.x \
Brad Bishop19323692019-04-05 15:28:33 -040028 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
29 file://0001-Do-not-read-config-files-from-HOME.patch \
30 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
31 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
32 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
33 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
34 file://0001-Fix-build-with-musl-C-library.patch \
35 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
36 file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
Brad Bishop19323692019-04-05 15:28:33 -040037 file://0001-perl-disable-auto-reqs.patch \
38 file://0001-rpm-rpmio.c-restrict-virtual-memory-usage-if-limit-s.patch \
39 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050041 file://0001-rpmfc.c-do-not-run-file-classification-in-parallel.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050042 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050043 file://0001-Bump-up-the-limit-of-signature-header-to-64MB.patch \
Brad Bishop19323692019-04-05 15:28:33 -040044 "
45
46PE = "1"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050047SRCREV = "ab2179452c5be276a6b96c591afded485c7e58c3"
Brad Bishop19323692019-04-05 15:28:33 -040048
49S = "${WORKDIR}/git"
50
Andrew Geissler82c905d2020-04-13 13:39:40 -050051DEPENDS = "openssl libarchive db file popt xz bzip2 dbus elfutils python3"
Brad Bishop19323692019-04-05 15:28:33 -040052DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
53
54inherit autotools gettext pkgconfig python3native
55export PYTHON_ABI
56
57# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
58EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
59
Andrew Geissler82c905d2020-04-13 13:39:40 -050060EXTRA_OECONF_append = " --without-lua --enable-python --with-crypto=openssl"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050061EXTRA_OECONF_append_libc-musl = " --disable-nls --disable-openmp"
Brad Bishop19323692019-04-05 15:28:33 -040062
63# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
64#
65# --localstatedir prevents rpm from writing its database to native sysroot when building images
66#
67# Disable dbus for native, so that rpm doesn't attempt to inhibit shutdown via session dbus even when plugins support is enabled.
68# Also disable plugins by default for native.
69EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050070EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --disable-plugins"
Brad Bishop19323692019-04-05 15:28:33 -040071
72BBCLASSEXTEND = "native nativesdk"
73
74PACKAGECONFIG ??= ""
75PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
76
77ASNEEDED = ""
78
79# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
80# libmagic also has sysroot path contamination, so override it
81
82WRAPPER_TOOLS = " \
83 ${bindir}/rpm \
84 ${bindir}/rpm2archive \
85 ${bindir}/rpm2cpio \
86 ${bindir}/rpmbuild \
87 ${bindir}/rpmdb \
88 ${bindir}/rpmgraph \
89 ${bindir}/rpmkeys \
90 ${bindir}/rpmsign \
91 ${bindir}/rpmspec \
92 ${libdir}/rpm/rpmdeps \
93"
94
95do_install_append_class-native() {
96 for tool in ${WRAPPER_TOOLS}; do
97 create_wrapper ${D}$tool \
98 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
99 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
100 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
101 RPM_NO_CHROOT_FOR_SCRIPTS=1
102 done
103}
104
105do_install_append_class-nativesdk() {
106 for tool in ${WRAPPER_TOOLS}; do
107 create_wrapper ${D}$tool \
108 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
109 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
110 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
111 RPM_NO_CHROOT_FOR_SCRIPTS=1
112 done
113
114 rm -rf ${D}/var
115}
116
117# Rpm's make install creates var/tmp which clashes with base-files packaging
118do_install_append_class-target() {
119 rm -rf ${D}/var
120}
121
122do_install_append () {
123 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
124 ${D}/${libdir}/rpm/macros
125
126 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
Andrew Geissler4b740dc2020-05-05 08:54:39 -0500127 ${D}${libdir}/rpm/pythondistdeps.py
Brad Bishop19323692019-04-05 15:28:33 -0400128}
129
130FILES_${PN} += "${libdir}/rpm-plugins/*.so \
131 "
132
133FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \
134 "
135
136PACKAGES += "python3-rpm"
137PROVIDES += "python3-rpm"
138FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
139
140# rpm 5.x was packaging the rpm build tools separately
141RPROVIDES_${PN} += "rpm-build"
142
143RDEPENDS_${PN} = "bash perl python3-core"
144
145PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
146
147# Do not specify a sysroot when compiling on a target.
148rpm_package_preprocess () {
149 sed -i -e 's:--sysroot[^ ]*::g' \
150 ${PKGD}/${libdir}/rpm/macros
151}