blob: 896162a2510286cb6251f3ecb3860c6b0ecd654c [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3"
2DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \
3mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \
4and also can write the decoded audio to WAV."
5HOMEPAGE = "http://mpg123.de/"
6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
7SECTION = "multimedia"
8
9LICENSE = "LGPLv2.1"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060010LIC_FILES_CHKSUM = "file://COPYING;md5=e7b9c15fcfb986abb4cc5e8400a24169"
Brad Bishop316dfdd2018-06-25 12:45:53 -040011
Andrew Geissler5a43b432020-06-13 10:46:56 -050012SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2"
Andrew Geissler5f350902021-07-23 13:09:54 -040013SRC_URI[sha256sum] = "7eefd4b68fdac7e138d04c37efe12155a8ebf25a5bccf0fb7e775af22d21db00"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
Andrew Geissler4ed12e12020-06-05 18:00:41 -050015UPSTREAM_CHECK_REGEX = "mpg123-(?P<pver>\d+(\.\d+)+)\.tar"
16
Brad Bishop316dfdd2018-06-25 12:45:53 -040017inherit autotools pkgconfig
18
19# The options should be mutually exclusive for configuration script.
20# If both alsa and pulseaudio are specified (as in the default distro features)
21# pulseaudio takes precedence.
22PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
23PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
24
25PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
26PACKAGECONFIG[esd] = ",,esound"
27PACKAGECONFIG[jack] = ",,jack"
28PACKAGECONFIG[openal] = ",,openal-soft"
29PACKAGECONFIG[portaudio] = ",,portaudio-v19"
30PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
Brad Bishopc342db32019-05-15 21:57:59 -040031PACKAGECONFIG[sdl] = ",,libsdl2"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032
33# Following are possible sound output modules:
34# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi
35AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}"
36AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
37
38EXTRA_OECONF = " \
39 --enable-shared \
40 --with-audio='${AUDIOMODS}' \
41 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
42 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060043 ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-cpu=generic_nofpu', '', d)} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040044"
45# Fails to build with thumb-1 (qemuarm)
46#| {standard input}: Assembler messages:
47#| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4'
48#| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24'
49#...
50#| make[3]: *** [equalizer.lo] Error 1
Patrick Williams213cb262021-08-07 19:21:33 -050051ARM_INSTRUCTION_SET:armv4 = "arm"
52ARM_INSTRUCTION_SET:armv5 = "arm"