blob: 52776704539ec1df2da355de4846ded73c69a86e [file] [log] [blame]
Patrick Venture9afb6712018-09-17 17:14:46 -07001SUMMARY = "Google Sys OEM commands"
Patrick Ventureedb61922018-09-21 14:57:58 -07002DESCRIPTION = "Google Sys OEM commands"
Patrick Venture3adb97a2018-09-26 08:42:56 -07003HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture9afb6712018-09-17 17:14:46 -07008
9inherit autotools pkgconfig
Patrick Venture9afb6712018-09-17 17:14:46 -070010inherit systemd
11inherit obmc-phosphor-ipmiprovider-symlink
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbusplus"
15DEPENDS += "phosphor-logging"
Patrick Venture9afb6712018-09-17 17:14:46 -070016DEPENDS += "phosphor-ipmi-host"
Patrick Venture9668c752019-02-06 09:50:22 -080017DEPENDS += "nlohmann-json"
Patrick Venture9afb6712018-09-17 17:14:46 -070018
Patrick Venture9afb6712018-09-17 17:14:46 -070019S = "${WORKDIR}/git"
20SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
Andrew Geisslerebe8cf52019-03-25 19:20:32 +000021SRCREV = "ba32fe4e25329f90bc8ab3d2e554dfe8615998d2"
Patrick Venture9afb6712018-09-17 17:14:46 -070022
23FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
25FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
26FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
27
28HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
29
30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
32
33do_install_append() {
34 install -d ${D}${systemd_system_unitdir}
35 install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
36}