blob: e43a5b434eca16b5b8c2fc35bf9e2ca22dddf3fd [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-systemd
9
10DEPENDS += "autoconf-archive-native"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093011RDEPENDS_${PN} += "libsystemd"
Cyril Burb73580e2017-01-12 18:13:30 +110012
13S = "${WORKDIR}/git"
14
Patrick Williams7783a042017-01-25 07:13:21 -060015SRC_URI += "git://github.com/openbmc/mboxbridge.git"
Cyril Burb73580e2017-01-12 18:13:30 +110016
17SRC_URI += "file://99-aspeed-mbox.rules"
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103018SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Burb73580e2017-01-12 18:13:30 +110019SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
20
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093021SRCREV="ded91bc53dafdb86ac4f203cc9d3006573fc407f"
22
23PROVIDES += "mboxctl"
Cyril Burb73580e2017-01-12 18:13:30 +110024
25MBOXD_FLASH_SIZE ??= "32M"
26SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
27
28# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
29# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanc8afc6a2017-03-09 10:28:09 -060030CFLAGS_append = " -I include"
Cyril Burb73580e2017-01-12 18:13:30 +110031
32do_install_append() {
33 install -d ${D}/lib/udev/rules.d
34 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103035 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Burb73580e2017-01-12 18:13:30 +110036}
Matt Spinler9f77d282017-01-20 15:32:07 -060037
38TMPL = "mboxd-reload@.service"
Andrew Geissler821d0742017-01-30 13:41:05 -060039TGTFMT = "obmc-power-chassis-off@{0}.target"
Matt Spinler9f77d282017-01-20 15:32:07 -060040INSTFMT = "mboxd-reload@{0}.service"
41FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
42
43SYSTEMD_SERVICE_${PN} += "mboxd.service"
44SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
45SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"