Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools to manipulate UEFI variables" |
| 2 | DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility" |
| 3 | HOMEPAGE = "https://github.com/rhboot/efivar" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" |
| 7 | |
| 8 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 9 | |
| 10 | SRC_URI = "git://github.com/rhinstaller/efivar.git \ |
| 11 | file://no-werror.patch" |
| 12 | SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit pkgconfig |
| 17 | |
| 18 | export CCLD_FOR_BUILD = "${BUILD_CCLD}" |
| 19 | |
| 20 | # Upstream uses --add-needed in gcc.specs which gold doesn't support, so |
| 21 | # enforce BFD. |
| 22 | LDFLAGS += "-fuse-ld=bfd" |
| 23 | |
| 24 | do_compile_prepend() { |
| 25 | # Remove when https://github.com/rhboot/efivar/issues/130 is fixed |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 26 | oe_runmake \ |
| 27 | CFLAGS="${BUILD_CFLAGS}" \ |
| 28 | LDFLAGS="${BUILD_LDFLAGS}" \ |
| 29 | -C src makeguids |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 30 | } |
| 31 | |
| 32 | do_install() { |
| 33 | oe_runmake install DESTDIR=${D} |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native" |
| 37 | |
| 38 | RRECOMMENDS_${PN}_class-target = "kernel-module-efivarfs" |
| 39 | |
| 40 | CLEANBROKEN = "1" |