blob: 91658f6bd7889633d29089a65c185e64b46c6a97 [file] [log] [blame]
vishwabmc2ac6f932015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc2ac6f932015-10-09 15:51:50 +05303PR = "r1"
4
Brad Bishop8fffc162016-08-19 09:02:54 -05005RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen9d3325a2015-10-24 19:34:11 -05006
Matthew Barth6b136a42016-08-16 16:51:35 -05007inherit autotools pkgconfig
vishwabmc2ac6f932015-10-09 15:51:50 +05308inherit obmc-phosphor-license
Patrick Williams89b11a12015-10-15 15:20:20 -05009inherit obmc-phosphor-sdbus-service
Tom Josephdcdc8ea2017-02-01 19:47:27 +053010inherit obmc-phosphor-ipmiprovider-symlink
Ratan Gupta3aa591f2017-03-06 17:05:11 +053011inherit phosphor-ipmi-host
12inherit pythonnative
Andrew Geisslerecfa6622017-05-11 16:16:27 -050013inherit obmc-phosphor-systemd
vishwabmc2ac6f932015-10-09 15:51:50 +053014
Adriana Kobylakc009f892017-02-17 08:21:42 -060015DEPENDS += "phosphor-logging"
Brad Bishop12e3d602016-10-05 20:10:23 -040016DEPENDS += "phosphor-mapper"
Matthew Barth6b136a42016-08-16 16:51:35 -050017DEPENDS += "autoconf-archive-native"
Tom Joseph1562bbc2017-02-20 12:01:43 +053018DEPENDS += "packagegroup-obmc-ipmid-providers"
Ratan Gupta3aa591f2017-03-06 17:05:11 +053019DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Ratan Guptaca8fd9d2017-03-20 18:20:47 +053020DEPENDS += "sdbusplus"
21DEPENDS += "phosphor-dbus-interfaces"
Andrew Geisslerecfa6622017-05-11 16:16:27 -050022DEPENDS += "obmc-targets"
Tom Josephcf7e8492017-05-08 11:49:10 +053023DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Ratan Gupta3aa591f2017-03-06 17:05:11 +053024
Adriana Kobylakc009f892017-02-17 08:21:42 -060025RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop12e3d602016-10-05 20:10:23 -040026RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller IIb8c51742016-03-04 15:29:29 -060027RDEPENDS_${PN} += "clear-once"
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060028RDEPENDS_${PN} += "network"
Brad Bishopea4022a2016-07-26 15:52:01 -040029RDEPENDS_${PN} += "libmapper"
Vishwanatha Subbannab1c39e02016-11-10 21:52:46 +053030RDEPENDS_${PN} += "phosphor-time-manager"
Ratan Guptaca8fd9d2017-03-20 18:20:47 +053031RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053032RDEPENDS_${PN} += "virtual/obmc-watchdog"
Ratan Guptaca8fd9d2017-03-20 18:20:47 +053033
Vishwanatha Subbannacaff3fa2017-03-31 14:41:11 +053034SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
35
Adriana Kobylak1ffadd92016-08-25 10:07:34 -050036RRECOMMENDS_${PN} += "virtual-obmc-settings-mgmt"
vishwabmc2ac6f932015-10-09 15:51:50 +053037
Marri Devender Rao2ba514e2017-06-08 00:47:54 -050038require ${PN}.inc
Chris Austen9d3325a2015-10-24 19:34:11 -050039
Tom Joseph1562bbc2017-02-20 12:01:43 +053040# Setup IPMI Whitelist Conf files
41WHITELIST_CONF = " \
Patrick Williams43b61b72017-02-24 13:04:06 -060042 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Joseph1562bbc2017-02-20 12:01:43 +053043 ${S}/host-ipmid-whitelist.conf \
44 "
45EXTRA_OECONF = " \
46 WHITELIST_CONF="${WHITELIST_CONF}" \
Ratan Gupta3aa591f2017-03-06 17:05:11 +053047 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephcf7e8492017-05-08 11:49:10 +053048 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Tom Joseph1562bbc2017-02-20 12:01:43 +053049 "
50
vishwabmc2ac6f932015-10-09 15:51:50 +053051S = "${WORKDIR}/git"
52
Tom Josephdcdc8ea2017-02-01 19:47:27 +053053HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053054HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
55
56NETIPMI_PROVIDER_LIBRARY += "libapphandler.so"
57
58FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barth6b136a42016-08-16 16:51:35 -050059FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053060FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
61FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop6371e702016-09-06 13:03:39 -040062
Andrew Geissler41e3cb32017-01-04 11:11:50 -060063# Soft Power Off
64RDEPENDS_${PN} += "phosphor-mapper"
Andrew Geisslerecfa6622017-05-11 16:16:27 -050065
66# install the soft power off service in the host shutdown target
67SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
68SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
69SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
70SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"