blob: 9ec77fdc4d11ce6a00a9a5bdfe43c2d1410c418d [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1"
6
Brad Bishop757e94a2018-09-07 18:58:51 +00007SRC_URI = " \
8 git://repo.or.cz/openocd.git;protocol=http;name=openocd \
9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
Brad Bishop26bdd442019-08-16 17:08:17 -040012 file://0001-Do-not-include-syscrtl.h-with-glibc.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
Brad Bishop757e94a2018-09-07 18:58:51 +000015SRCREV_FORMAT = "openocd"
Brad Bishop2f973922019-11-11 07:58:48 -050016SRCREV_openocd = "ded67990255cc1e63c77832ffd6e6bef9120873d"
Brad Bishop757e94a2018-09-07 18:58:51 +000017SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
Brad Bishop2f973922019-11-11 07:58:48 -050018SRCREV_jimtcl = "dc4ba7770d580800634f90b67a24e077b4a26d98"
19SRCREV_libjaylink = "cfccbc9d6763733f1d14dff3c2dc5b75aaef136b"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020
21PV = "0.10+gitr${SRCPV}"
22S = "${WORKDIR}/git"
23
24inherit pkgconfig autotools-brokensep gettext
25
Brad Bishop2f973922019-11-11 07:58:48 -050026BBCLASSEXTEND += "native nativesdk"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027
Brad Bishopa891d152019-09-13 06:17:45 -040028EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror"
29
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030do_configure() {
Brad Bishop757e94a2018-09-07 18:58:51 +000031 ./bootstrap nosubmodule
Brad Bishop19323692019-04-05 15:28:33 -040032 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup
33 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/jimtcl/autosetup
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034 oe_runconf ${EXTRA_OECONF}
35}
36
37do_install() {
38 oe_runmake DESTDIR=${D} install
39 if [ -e "${D}${infodir}" ]; then
40 rm -Rf ${D}${infodir}
41 fi
42 if [ -e "${D}${mandir}" ]; then
43 rm -Rf ${D}${mandir}
44 fi
45 if [ -e "${D}${bindir}/.debug" ]; then
46 rm -Rf ${D}${bindir}/.debug
47 fi
48}
49
50FILES_${PN} = " \
51 ${datadir}/openocd/* \
52 ${bindir}/openocd \
53 "
54
55PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
56PACKAGECONFIG ??= "sysfsgpio"