blob: d540d4214eb8786cde90f8185415e25d0aaded39 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Class for packagegroup (package group) recipes
2
3# By default, only the packagegroup package itself is in PACKAGES.
4# -dbg and -dev flavours are handled by the anonfunc below.
5# This means that packagegroup recipes used to build multiple packagegroup
6# packages have to modify PACKAGES after inheriting packagegroup.bbclass.
7PACKAGES = "${PN}"
8
9# By default, packagegroup packages do not depend on a certain architecture.
10# Only if dependencies are modified by MACHINE_FEATURES, packages
11# need to be set to MACHINE_ARCH after inheriting packagegroup.bbclass
12PACKAGE_ARCH ?= "all"
13
14# Fully expanded - so it applies the overrides as well
15PACKAGE_ARCH_EXPANDED := "${PACKAGE_ARCH}"
16
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017LICENSE ?= "MIT"
18
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019inherit ${@oe.utils.ifelse(d.getVar('PACKAGE_ARCH_EXPANDED') == 'all', 'allarch', '')}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21# This automatically adds -dbg and -dev flavours of all PACKAGES
22# to the list. Their dependencies (RRECOMMENDS) are handled as usual
23# by package_depchains in a following step.
24# Also mark all packages as ALLOW_EMPTY
25python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 packages = d.getVar('PACKAGES').split()
27 if d.getVar('PACKAGEGROUP_DISABLE_COMPLEMENTARY') != '1':
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028 types = ['', '-dbg', '-dev']
29 if bb.utils.contains('DISTRO_FEATURES', 'ptest', True, False, d):
30 types.append('-ptest')
31 packages = [pkg + suffix for pkg in packages
32 for suffix in types]
33 d.setVar('PACKAGES', ' '.join(packages))
34 for pkg in packages:
35 d.setVar('ALLOW_EMPTY_%s' % pkg, '1')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036}
37
38# We don't want to look at shared library dependencies for the
39# dbg packages
40DEPCHAIN_DBGDEFAULTDEPS = "1"
41
42# We only need the packaging tasks - disable the rest
Brad Bishop6e60e8b2018-02-01 10:27:11 -050043deltask do_fetch
44deltask do_unpack
45deltask do_patch
46deltask do_configure
47deltask do_compile
48deltask do_install
49deltask do_populate_sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050
51python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050052 if bb.data.inherits_class('nativesdk', d):
53 return
54 initman = d.getVar("VIRTUAL-RUNTIME_init_manager")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055 if initman and initman in ['sysvinit', 'systemd'] and not bb.utils.contains('DISTRO_FEATURES', initman, True, False, d):
56 bb.fatal("Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (%s) matches the entries enabled in DISTRO_FEATURES" % initman)
57}
58
Brad Bishop316dfdd2018-06-25 12:45:53 -040059CVE_PRODUCT = ""