blob: 1c07ad59d42c49565439fdd62f066f0f94ead744 [file] [log] [blame]
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05001SUMMARY = "PLDM Stack"
2DESCRIPTION = "Implementation of the PLDM specifications"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit meson pkgconfig
Deepak Kodihallia7482012020-06-22 05:25:35 -05007inherit systemd
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05008
9require pldm.inc
10
11DEPENDS += "systemd"
Matt Spinlere2375b52020-01-20 14:09:47 -060012DEPENDS += "sdeventplus"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050013DEPENDS += "phosphor-dbus-interfaces"
14DEPENDS += "nlohmann-json"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050015DEPENDS += "cli11"
16
17S = "${WORKDIR}/git"
18
Deepak Kodihallia7482012020-06-22 05:25:35 -050019SYSTEMD_SERVICE_${PN} += "pldmd.service"
Chicago Duanf42ff2c2020-08-27 15:07:55 +080020SYSTEMD_SERVICE_${PN} += "pldmSoftPowerOff.service"
Deepak Kodihallia7482012020-06-22 05:25:35 -050021
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050022EXTRA_OEMESON = " \
23 -Dtests=disabled \
24 -Doem-ibm=disabled \
25 "
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050026
27# Install pldmSoftPowerOff.service in correct targets
28pkg_postinst_${PN} () {
29
30 mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
31 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
32 TARGET="../pldmSoftPowerOff.service"
33 ln -s $TARGET $LINK
34
35 mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
36 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
37 TARGET="../pldmSoftPowerOff.service"
38 ln -s $TARGET $LINK
39}
40
41pkg_prerm_${PN} () {
42
43 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
44 rm $LINK
45
46 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
47 rm $LINK
48}