blob: d9c25170576263614269ad1c6f205f1cdada98c0 [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001SUMMARY = "C library and tools for interacting with the linux GPIO character device"
2AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003
Andrew Geisslera2681d92020-10-16 10:17:07 -05004LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geisslerac970dd2021-02-12 15:32:45 -06007SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz \
8 file://run-ptest \
9"
10
Andrew Geissler32b11992021-03-31 13:37:05 -050011SRC_URI[md5sum] = "28e79f6f70fee1da9079558d8b7b3736"
12SRC_URI[sha256sum] = "841be9d788f00bab08ef22c4be5c39866f0e46cb100a3ae49ed816ac9c5dddc7"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
Andrew Geisslerac970dd2021-02-12 15:32:45 -060014inherit autotools pkgconfig python3native ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
Andrew Geissler8fc454f2020-12-11 16:27:59 -060016PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev glib-2.0 catch2"
Andrew Geisslera2681d92020-10-16 10:17:07 -050017PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
19
Andrew Geisslera2681d92020-10-16 10:17:07 -050020# Enable cxx bindings by default.
21PACKAGECONFIG ?= "cxx"
22
23# Always build tools - they don't have any additional
24# requirements over the library.
25EXTRA_OECONF = "--enable-tools"
26
27DEPENDS += "autoconf-archive-native"
28
29PACKAGES =+ "${PN}-tools libgpiodcxx"
30FILES_${PN}-tools = "${bindir}/*"
31FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032
33PACKAGES =+ "${PN}-python"
Andrew Geissler97771a32021-03-05 15:23:11 -060034FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*.so"
35FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
Andrew Geissler82c905d2020-04-13 13:39:40 -050036RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
37RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060038
39PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'tests', '', d)}"
40
41do_install_ptest() {
42 install -d ${D}${PTEST_PATH}/tests
43 cp ${B}/tests/.libs/gpiod-test ${D}${PTEST_PATH}/tests/
44}