Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images" |
| 2 | DESCRIPTION = "The gd graphics library allows your code to quickly draw images \ |
| 3 | complete with lines, arcs, text, multiple colors, cut and paste from other \ |
| 4 | images, and flood fills, and to write out the result as a PNG or JPEG file. \ |
| 5 | This is particularly useful in Web applications, where PNG and JPEG are two \ |
| 6 | of the formats accepted for inline images by most browsers. Note that gd is not \ |
| 7 | a paint program." |
| 8 | HOMEPAGE = "http://libgd.github.io/" |
| 9 | |
| 10 | SECTION = "libs" |
| 11 | LICENSE = "GD" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=ace63adfdac78400fc30fa22ee9c1bb1" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS = "freetype libpng jpeg zlib tiff" |
| 15 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | SRC_URI = "git://github.com/libgd/libgd.git;nobranch=1;protocol=https \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 17 | file://0001-Fix-deprecared-function-prototypes.patch \ |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 18 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 20 | SRCREV = "b5319a41286107b53daa0e08e402aa1819764bdc" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit autotools binconfig gettext pkgconfig |
| 25 | |
| 26 | EXTRA_OECONF += " --disable-rpath \ |
| 27 | --with-jpeg=${STAGING_LIBDIR}/.. \ |
| 28 | --with-freetype=yes \ |
| 29 | --without-fontconfig \ |
| 30 | --without-webp \ |
| 31 | --without-xpm \ |
| 32 | --without-x \ |
| 33 | " |
| 34 | |
| 35 | EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"' |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | do_install:append:class-target() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 40 | # cleanup buildpaths from gdlib.pc |
| 41 | sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc |
| 42 | } |
| 43 | |
| 44 | PACKAGES += "${PN}-tools" |
| 45 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | FILES:${PN} = "${libdir}/lib*${SOLIBS}" |
| 47 | FILES:${PN}-tools = "${bindir}/*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 48 | |
| 49 | PROVIDES += "${PN}-tools" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | RPROVIDES:${PN}-tools = "${PN}-tools" |
| 51 | RDEPENDS:${PN}-tools = "perl perl-module-strict" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 52 | |
| 53 | CVE_PRODUCT = "libgd" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 54 | |
| 55 | BBCLASSEXTEND = "native nativesdk" |