blob: 3fd7c536bc0447480f6d1bc89ce496a803761652 [file] [log] [blame]
Brad Bishop0f547b12017-05-31 14:08:33 -04001SUMMARY = "Phosphor DBus Monitor"
2DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \
3that watches DBus traffic for events and takes actions based on those events."
4PR = "r1"
5
6HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
Andrew Geissler36b64c02018-09-05 00:30:15 +000010SRCREV = "3d6d3182ee0b0e88b81fbbbe5c91dea3e99425a9"
Brad Bishop0f547b12017-05-31 14:08:33 -040011
12inherit autotools \
13 pkgconfig \
14 pythonnative \
15 phosphor-dbus-monitor \
16 obmc-phosphor-systemd
17
Brad Bishop48628b42017-08-02 01:32:43 -040018PACKAGE_BEFORE_PN = "phosphor-msl-verify"
19SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify"
20SYSTEMD_SERVICE_phosphor-msl-verify = "phosphor-msl-verify.service"
21
Brad Bishop0f547b12017-05-31 14:08:33 -040022DEPENDS += " \
23 ${PN}-config-native \
24 phosphor-logging \
25 autoconf-archive-native \
Brad Bishop04ff12c2018-01-26 21:48:20 -050026 sdbusplus-native \
Brad Bishop0f547b12017-05-31 14:08:33 -040027 gtest \
Andrew Geissler36b64c02018-09-05 00:30:15 +000028 phosphor-snmp \
Brad Bishop0f547b12017-05-31 14:08:33 -040029 "
30RDEPENDS_${PN} += " \
31 sdbusplus \
32 phosphor-dbus-interfaces \
33 phosphor-logging \
Andrew Geissler36b64c02018-09-05 00:30:15 +000034 phosphor-snmp \
Brad Bishop0f547b12017-05-31 14:08:33 -040035 "
36
Brad Bishop48628b42017-08-02 01:32:43 -040037RDEPENDS_phosphor-msl-verify += " \
38 sdbusplus \
39 phosphor-dbus-interfaces \
40 phosphor-logging \
Andrew Geissler36b64c02018-09-05 00:30:15 +000041 phosphor-snmp \
Brad Bishop48628b42017-08-02 01:32:43 -040042 "
43FILES_phosphor-msl-verify = "${sbindir}/phosphor-msl-verify"
44
Brad Bishop0f547b12017-05-31 14:08:33 -040045S = "${WORKDIR}/git"
46
47EXTRA_OECONF = " \
48 YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \
49 "