blob: c2bc8bcb3291aa6b24049a701ee98e6ed477c2a2 [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Adriana Kobylak9ede23c2017-02-09 13:43:22 -060011inherit phosphor-dbus-interfaces
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050012inherit phosphor-logging
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050013
14DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
15
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams845123d2016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihalli0ac54522017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Rao3b1e30e2017-05-14 09:01:35 -050023DEPENDS += "phosphor-logging-error-logs-native"
Adriana Kobylak385287c2017-02-09 15:06:41 -060024RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050025PROVIDES += "virtual/obmc-logging-mgmt"
26RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
27
Michael Tritz026fbaf2017-03-13 14:54:24 -050028PACKAGE_BEFORE_PN = "${PN}-test"
29FILES_${PN}-test = "${bindir}/*-test"
30
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050031SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williamse5da1312017-05-29 20:40:05 -050032SRCREV = "1eb58922d3ca4fa61916accfd20fe0c28ac06430"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050033
34S = "${WORKDIR}/git"
35
Deepak Kodihalli430a5062017-03-28 07:47:51 -050036PACKAGECONFIG ??= "metadata-processing"
37PACKAGECONFIG[metadata-processing] = " \
38 --enable-metadata-processing, \
39 --disable-metadata-processing, , \
40 "
41
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050042EXTRA_OECONF = " \
43 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
44 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
45 "