blob: 7d1bce558d1eb8d8a4282aad2d8a3f904a5bf89c [file] [log] [blame]
Andrew Geissler4ed12e12020-06-05 18:00:41 -05001SUMMARY = "Advanced front-end for dpkg"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "APT is the Advanced Package Tool, an advanced interface to the Debian packaging system which provides the apt-get program."
3HOMEPAGE = "https://packages.debian.org/jessie/apt"
Andrew Geissler4ed12e12020-06-05 18:00:41 -05004LICENSE = "GPLv2.0+"
5SECTION = "base"
6
7# Triehash script taken from https://github.com/julian-klode/triehash
8SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/${BPN}_${PV}.tar.xz \
9 file://triehash \
10 file://0001-Disable-documentation-directory-altogether.patch \
11 file://0001-Fix-musl-build.patch \
12 file://0001-CMakeLists.txt-avoid-changing-install-paths-based-on.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050013 file://0001-srvrec-Keep-support-for-older-resolver.patch \
14 file://0001-cmake-Do-not-build-po-files.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050015 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050016
Andrew Geissler4ed12e12020-06-05 18:00:41 -050017SRC_URI_append_class-native = " \
18 file://0001-Do-not-init-tables-from-dpkg-configuration.patch \
19 file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050020 "
21
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022SRC_URI_append_class-nativesdk = " \
23 file://0001-Do-not-init-tables-from-dpkg-configuration.patch \
24 file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060025 "
26
Andrew Geissler95ac1b82021-03-31 14:34:31 -050027SRC_URI[sha256sum] = "c5449a4c2126a12497a9949cd10209926005d329f6ce7942a3781fa2fcf50487"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050028LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263"
29
30# the package is taken from snapshots.debian.org; that source is static and goes stale
31# so we check the latest upstream from a directory that does get updated
32UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/apt/"
33
Andrew Geisslerd1e89492021-02-12 15:35:20 -060034inherit cmake perlnative bash-completion upstream-version-is-even useradd
Andrew Geissler4ed12e12020-06-05 18:00:41 -050035
Andrew Geisslerd1e89492021-02-12 15:35:20 -060036# User is added to allow apt to drop privs, will runtime warn without
37USERADD_PACKAGES = "${PN}"
38USERADD_PARAM_${PN} = "--system --home /nonexistent --no-create-home _apt"
39
40BBCLASSEXTEND = "native nativesdk"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050041
Andrew Geissler95ac1b82021-03-31 14:34:31 -050042DEPENDS += "db gnutls lz4 zlib bzip2 xz libgcrypt xxhash"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050043
Andrew Geisslerd1e89492021-02-12 15:35:20 -060044EXTRA_OECMAKE_append = " -DCURRENT_VENDOR=debian -DWITH_DOC=False \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050045 -DDPKG_DATADIR=${datadir}/dpkg \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060046 -DTRIEHASH_EXECUTABLE=${WORKDIR}/triehash \
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050047 -DCMAKE_DISABLE_FIND_PACKAGE_ZSTD=True \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050048 -DWITH_TESTS=False \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060049"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050050
51do_configure_prepend () {
52 echo "set( CMAKE_FIND_ROOT_PATH_MODE_INCLUDE BOTH )" >> ${WORKDIR}/toolchain.cmake
53
54}
55
56# Unfortunately apt hardcodes this all over the place
57FILES_${PN} += "${prefix}/lib/dpkg ${prefix}/lib/apt"
58RDEPENDS_${PN} += "bash perl dpkg"
59
Andrew Geisslerd1e89492021-02-12 15:35:20 -060060customize_apt_conf_sample() {
Andrew Geissler4ed12e12020-06-05 18:00:41 -050061 cat > ${D}${sysconfdir}/apt/apt.conf.sample << EOF
62Dir "${STAGING_DIR_NATIVE}/"
63{
64 State "var/lib/apt/"
65 {
66 Lists "#APTCONF#/lists/";
67 status "#ROOTFS#/var/lib/dpkg/status";
68 };
69 Cache "var/cache/apt/"
70 {
71 Archives "archives/";
72 pkgcache "";
73 srcpkgcache "";
74 };
75 Bin "${STAGING_BINDIR_NATIVE}/"
76 {
77 methods "${STAGING_LIBDIR}/apt/methods/";
78 gzip "/bin/gzip";
79 dpkg "dpkg";
80 dpkg-source "dpkg-source";
81 dpkg-buildpackage "dpkg-buildpackage";
82 apt-get "apt-get";
83 apt-cache "apt-cache";
84 };
85 Etc "#APTCONF#"
86 {
87 Preferences "preferences";
88 };
89 Log "var/log/apt";
90};
91
92APT
93{
94 Install-Recommends "true";
95 Immediate-Configure "false";
96 Architecture "i586";
97 Get
98 {
99 Assume-Yes "true";
100 };
101};
102
103Acquire
104{
105 AllowInsecureRepositories "true";
106};
107
108DPkg::Options {"--root=#ROOTFS#";"--admindir=#ROOTFS#/var/lib/dpkg";"--force-all";"--no-debsig"};
109DPkg::Path "";
110EOF
111}
112
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600113do_install_append_class-native() {
114 customize_apt_conf_sample
115}
116
117do_install_append_class-nativesdk() {
118 customize_apt_conf_sample
119}
120
121
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500122do_install_append_class-target() {
123 #Write the correct apt-architecture to apt.conf
124 APT_CONF=${D}/etc/apt/apt.conf
125 echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
126}
127
128# Avoid non-reproducible -src package
129do_install_append () {
130 sed -i -e "s,${B},,g" \
131 ${B}/apt-pkg/tagfile-keys.cc
132}