blob: f0a223a19c915486aa05e245934390245667d3b4 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
Andrew Geissler4b740dc2020-05-05 08:54:39 -050012SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz \
Brad Bishop19323692019-04-05 15:28:33 -040013 file://disable-check.patch \
Brad Bishop19323692019-04-05 15:28:33 -040014 "
15
Andrew Geissler4b740dc2020-05-05 08:54:39 -050016SRC_URI[sha256sum] = "a55ed6db98d43469801262d81dc2572ed124edc3db31059d4e9916eb9f844c34"
Brad Bishop19323692019-04-05 15:28:33 -040017
18BBCLASSEXTEND = "native nativesdk"
19
20DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
21
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050022PACKAGES_DYNAMIC = "^${PN}-.*"
Brad Bishop19323692019-04-05 15:28:33 -040023
24FILES_${PN} = "${libdir}/libxcb.so.*"
25
Brad Bishop6dbb3162019-11-25 09:41:34 -050026inherit autotools pkgconfig features_check
Brad Bishop19323692019-04-05 15:28:33 -040027
28# The libxau and others requires x11 in DISTRO_FEATURES
29REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishop19323692019-04-05 15:28:33 -040030
31export PYTHON = "python3"
32
Andrew Geissler6ce62a22020-11-30 19:58:47 -060033do_install_append () {
34 chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R
35}
36
Brad Bishop19323692019-04-05 15:28:33 -040037python populate_packages_prepend () {
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050038 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', '${PN}-%s', 'XCB library module for %s', allow_links=True)
Brad Bishop19323692019-04-05 15:28:33 -040039}