blob: a46c44bbd92918431125ddc3d7705eefa9a6e526 [file] [log] [blame]
Vijay Khemka45269ba2018-12-13 11:07:06 -08001FILESEXTRAPATHS_append := "${THISDIR}/files:"
2
Vijay Khemka3becf042019-01-08 10:45:20 -08003inherit obmc-phosphor-systemd
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a8328fd2a610bf4527feedcaa3ae3d14"
Vijay Khemka45269ba2018-12-13 11:07:06 -08006
7S = "${WORKDIR}/"
8
9SRC_URI = "file://setup_gpio.sh \
10 file://power-util \
11 file://host-gpio.service \
12 file://host-poweroff.service \
Vijay Khemka3becf042019-01-08 10:45:20 -080013 file://host-poweron.service \
14 file://LICENSE"
Vijay Khemka45269ba2018-12-13 11:07:06 -080015
16DEPENDS = "systemd"
17RDEPENDS_${PN} = "bash"
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
21
22do_install() {
23 install -d ${D}/usr/sbin
24 install -m 0755 ${S}setup_gpio.sh ${D}/${sbindir}/
25 install -m 0755 ${S}power-util ${D}/${sbindir}/
26}