blob: 1ffec62ed38c3c736a08aee637463ae5b9c81ea6 [file] [log] [blame]
Tom Joseph7b827742017-01-16 16:43:05 +05301SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
Patrick Ventureafba95a2018-10-01 20:54:34 -07005PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Tom Joseph7b827742017-01-16 16:43:05 +05308
9inherit autotools pkgconfig
Vernon Mauery33136592019-03-22 12:25:14 -070010inherit systemd
Tom Joseph7b827742017-01-16 16:43:05 +053011
12DEPENDS += "autoconf-archive-native"
Vernon Mauery3fcd42e2019-04-12 14:06:06 -070013DEPENDS += "cli11"
Tom Joseph7b827742017-01-16 16:43:05 +053014DEPENDS += "phosphor-mapper"
15DEPENDS += "systemd"
16DEPENDS += "phosphor-ipmi-host"
Tom Joseph7b827742017-01-16 16:43:05 +053017
18SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
Andrew Geissler3ddbbe12019-08-09 05:21:13 +000019SRCREV = "35ca150beb7d5faf2fe0ca44c87bc7b0ade0aee7"
Tom Joseph7b827742017-01-16 16:43:05 +053020
21S = "${WORKDIR}/git"
22
Vernon Mauery33136592019-03-22 12:25:14 -070023FILES_${PN} += " \
24 ${systemd_system_unitdir}/${PN}@.service \
25 ${systemd_system_unitdir}/${PN}@.socket \
Tom Joseph62b03f22017-01-27 14:11:58 +053026 "
Vernon Mauery33136592019-03-22 12:25:14 -070027
28# If RMCPP_IFACE is not set by bbappend, set it to default
29DEFAULT_RMCPP_IFACE = "eth0"
30RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
31
32# install parameterized service and socket files
33SYSTEMD_SERVICE_${PN} = " \
34 ${PN}@${RMCPP_IFACE}.service \
35 ${PN}@${RMCPP_IFACE}.socket \
36 "
37
38# To add another RMCPP interface, add similar lines to the
39# following lines in a bbappend:
40#
41# ALT_RMCPP_IFACE = "eth1"
42# SYSTEMD_SERVICE_${PN} += " \
43# ${PN}@${ALT_RMCPP_IFACE}.service \
44# ${PN}@${ALT_RMCPP_IFACE}.socket \
45# "
46
47# Also, be sure to enable a corresponding entry in the channel
48# config file with the same 'name' as the interfaces above
49# Override the default phosphor-ipmi-config.bb with a bbappend
50