Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Tools for taking the MD5 sum of ISO images" |
| 2 | DESCRIPTION = "Tools for taking the MD5 sum of ISO images" |
| 3 | |
| 4 | DEPENDS = "popt python3 openssl curl popt-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 5 | RDEPENDS:${BPN} = "openssl curl" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
| 9 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SRC_URI = "git://github.com/rhinstaller/isomd5sum.git;branch=master;protocol=https \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | file://0001-tweak-install-prefix.patch \ |
| 12 | file://0002-fix-parallel-error.patch \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | inherit python3native |
| 17 | |
| 18 | EXTRA_OEMAKE += " \ |
| 19 | DESTDIR='${D}' \ |
| 20 | PYTHONINCLUDE='-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}' \ |
| 21 | PYTHONSITEPACKAGES='${PYTHON_SITEPACKAGES_DIR}' \ |
| 22 | " |
| 23 | |
| 24 | do_install () { |
| 25 | oe_runmake install |
| 26 | } |
| 27 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 28 | PACKAGES += "${PYTHON_PN}-${BPN}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | RPROVIDES:${BPN}-dbg += "${PYTHON_PN}-${BPN}-dbg" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | FILES:${PYTHON_PN}-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/pyisomd5sum.so" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | |
| 34 | SRCREV = "7860901f726f5d92689cb67243cc7f981f21f74b" |
| 35 | |
| 36 | BBCLASSEXTEND = "native" |