blob: d754a6d7252d7034e102f0d5db21d51c0dcedc8d [file] [log] [blame]
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05301SUMMARY = "Phosphor Watchdog application"
2DESCRIPTION = "Application that implements software watchdog"
3HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog"
4PR = "r1"
Patrick Venturea1a628b2018-10-01 20:48:41 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venturea1a628b2018-10-01 20:48:41 -07008
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05309inherit autotools pkgconfig
10inherit obmc-phosphor-dbus-service
11
12RPROVIDES_${PN} += "virtual/obmc-watchdog"
13PROVIDES += "virtual/obmc-watchdog"
14
15DEPENDS += "autoconf-archive-native"
William A. Kennington IIIf33e9a12018-09-14 00:25:00 -070016DEPENDS += "cli11"
William A. Kennington IIIf37d0962019-03-27 20:21:26 -070017DEPENDS += "sdbusplus"
William A. Kennington III83d610a2018-09-13 23:32:19 -070018DEPENDS += "sdeventplus"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053019DEPENDS += "phosphor-dbus-interfaces"
20DEPENDS += "phosphor-logging"
Brad Bishop44f3cce2019-03-22 23:41:42 -040021DEPENDS += "systemd"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053022
23SRC_URI += "git://github.com/openbmc/phosphor-watchdog"
Andrew Geissler90e634a2019-03-21 00:52:44 +000024SRCREV = "50ae4b152ba8aaecd1a09634d2df7036f14e03ed"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053025S = "${WORKDIR}/git"
26
27# Copies config file having arguments for host watchdog
28SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron"
29
30# Install the override to set up a Conflicts relation
31SYSTEMD_OVERRIDE_${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
32
33# For now, watching PowerOn is the only usecase
34OBMC_HOST_WATCHDOG_INSTANCES = "poweron"
35
36# This is really a DBUS service but the service name is
37# an argument, so making it this way.
38WATCHDOG_TMPL = "phosphor-watchdog@.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053039ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053040SYSTEMD_SERVICE_${PN} += "${WATCHDOG_TMPL}"
41
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053042# To Enable Host Watchdog early during poweron
43SYSTEMD_SERVICE_${PN} += "${ENABLE_WATCHDOG_TMPL}"
44
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053045WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053046ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service"
47
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070048WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-startmin@{1}.target.wants/${WATCHDOG_TGTFMT}"
49ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-startmin@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053050
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053051SYSTEMD_LINK_${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053052SYSTEMD_LINK_${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"