blob: fa4ea6feef93ee3b20e075c36c9180bf0dd5ec67 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001inherit kernel-uboot kernel-artifact-names uboot-sign
Patrick Williamsc124f4f2015-09-15 14:41:29 -05002
3python __anonymous () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004 kerneltypes = d.getVar('KERNEL_IMAGETYPES') or ""
He Zhefe76b1e2016-05-25 04:47:16 -04005 if 'fitImage' in kerneltypes.split():
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006 depends = d.getVar("DEPENDS")
Brad Bishop19323692019-04-05 15:28:33 -04007 depends = "%s u-boot-tools-native dtc-native" % depends
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008 d.setVar("DEPENDS", depends)
9
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010 uarch = d.getVar("UBOOT_ARCH")
11 if uarch == "arm64":
12 replacementtype = "Image"
Brad Bishopc342db32019-05-15 21:57:59 -040013 elif uarch == "riscv":
14 replacementtype = "Image"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 elif uarch == "mips":
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 replacementtype = "vmlinuz.bin"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 elif uarch == "x86":
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018 replacementtype = "bzImage"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019 elif uarch == "microblaze":
20 replacementtype = "linux.bin"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021 else:
22 replacementtype = "zImage"
23
Brad Bishop19323692019-04-05 15:28:33 -040024 # Override KERNEL_IMAGETYPE_FOR_MAKE variable, which is internal
25 # to kernel.bbclass . We have to override it, since we pack zImage
26 # (at least for now) into the fitImage .
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027 typeformake = d.getVar("KERNEL_IMAGETYPE_FOR_MAKE") or ""
He Zhefe76b1e2016-05-25 04:47:16 -040028 if 'fitImage' in typeformake.split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060029 d.setVar('KERNEL_IMAGETYPE_FOR_MAKE', typeformake.replace('fitImage', replacementtype))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031 image = d.getVar('INITRAMFS_IMAGE')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032 if image:
George McCollister185c8ae2016-05-26 08:55:16 -050033 d.appendVarFlag('do_assemble_fitimage_initramfs', 'depends', ' ${INITRAMFS_IMAGE}:do_image_complete')
34
Brad Bishop19323692019-04-05 15:28:33 -040035 #check if there are any dtb providers
36 providerdtb = d.getVar("PREFERRED_PROVIDER_virtual/dtb")
37 if providerdtb:
38 d.appendVarFlag('do_assemble_fitimage', 'depends', ' virtual/dtb:do_populate_sysroot')
39 d.appendVarFlag('do_assemble_fitimage_initramfs', 'depends', ' virtual/dtb:do_populate_sysroot')
40 d.setVar('EXTERNAL_KERNEL_DEVICETREE', "${RECIPE_SYSROOT}/boot/devicetree")
41
Patrick Williamsc0f7c042017-02-23 20:41:17 -060042 # Verified boot will sign the fitImage and append the public key to
Brad Bishop6e60e8b2018-02-01 10:27:11 -050043 # U-Boot dtb. We ensure the U-Boot dtb is deployed before assembling
Patrick Williamsc0f7c042017-02-23 20:41:17 -060044 # the fitImage:
Brad Bishop15ae2502019-06-18 21:44:24 -040045 if d.getVar('UBOOT_SIGN_ENABLE') == "1" and d.getVar('UBOOT_DTB_BINARY'):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046 uboot_pn = d.getVar('PREFERRED_PROVIDER_u-boot') or 'u-boot'
Brad Bishop19323692019-04-05 15:28:33 -040047 d.appendVarFlag('do_assemble_fitimage', 'depends', ' %s:do_populate_sysroot' % uboot_pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048}
49
Yannick Gicqueld5813b42016-04-27 16:20:55 +020050# Options for the device tree compiler passed to mkimage '-D' feature:
51UBOOT_MKIMAGE_DTCOPTS ??= ""
52
Brad Bishopf3fd2882019-06-21 08:06:37 -040053# fitImage Hash Algo
54FIT_HASH_ALG ?= "sha256"
55
Brad Bishop64c979e2019-11-04 13:55:29 -050056# fitImage Signature Algo
57FIT_SIGN_ALG ?= "rsa2048"
58
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059#
60# Emit the fitImage ITS header
61#
George McCollister185c8ae2016-05-26 08:55:16 -050062# $1 ... .its filename
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063fitimage_emit_fit_header() {
George McCollister185c8ae2016-05-26 08:55:16 -050064 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065/dts-v1/;
66
67/ {
68 description = "U-Boot fitImage for ${DISTRO_NAME}/${PV}/${MACHINE}";
69 #address-cells = <1>;
70EOF
71}
72
73#
74# Emit the fitImage section bits
75#
George McCollister185c8ae2016-05-26 08:55:16 -050076# $1 ... .its filename
77# $2 ... Section bit type: imagestart - image section start
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078# confstart - configuration section start
79# sectend - section end
80# fitend - fitimage end
81#
82fitimage_emit_section_maint() {
George McCollister185c8ae2016-05-26 08:55:16 -050083 case $2 in
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 imagestart)
George McCollister185c8ae2016-05-26 08:55:16 -050085 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050086
87 images {
88EOF
89 ;;
90 confstart)
George McCollister185c8ae2016-05-26 08:55:16 -050091 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092
93 configurations {
94EOF
95 ;;
96 sectend)
George McCollister185c8ae2016-05-26 08:55:16 -050097 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050098 };
99EOF
100 ;;
101 fitend)
George McCollister185c8ae2016-05-26 08:55:16 -0500102 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103};
104EOF
105 ;;
106 esac
107}
108
109#
110# Emit the fitImage ITS kernel section
111#
George McCollister185c8ae2016-05-26 08:55:16 -0500112# $1 ... .its filename
113# $2 ... Image counter
114# $3 ... Path to kernel image
115# $4 ... Compression type
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500116fitimage_emit_section_kernel() {
117
Brad Bishopf3fd2882019-06-21 08:06:37 -0400118 kernel_csum="${FIT_HASH_ALG}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500119
Brad Bishop316dfdd2018-06-25 12:45:53 -0400120 ENTRYPOINT="${UBOOT_ENTRYPOINT}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500121 if [ -n "${UBOOT_ENTRYSYMBOL}" ]; then
122 ENTRYPOINT=`${HOST_PREFIX}nm vmlinux | \
123 awk '$3=="${UBOOT_ENTRYSYMBOL}" {print "0x"$1;exit}'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500124 fi
125
George McCollister185c8ae2016-05-26 08:55:16 -0500126 cat << EOF >> ${1}
127 kernel@${2} {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128 description = "Linux kernel";
George McCollister185c8ae2016-05-26 08:55:16 -0500129 data = /incbin/("${3}");
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500130 type = "kernel";
131 arch = "${UBOOT_ARCH}";
132 os = "linux";
George McCollister185c8ae2016-05-26 08:55:16 -0500133 compression = "${4}";
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134 load = <${UBOOT_LOADADDRESS}>;
135 entry = <${ENTRYPOINT}>;
136 hash@1 {
137 algo = "${kernel_csum}";
138 };
139 };
140EOF
141}
142
143#
144# Emit the fitImage ITS DTB section
145#
George McCollister185c8ae2016-05-26 08:55:16 -0500146# $1 ... .its filename
147# $2 ... Image counter
148# $3 ... Path to DTB image
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500149fitimage_emit_section_dtb() {
150
Brad Bishopf3fd2882019-06-21 08:06:37 -0400151 dtb_csum="${FIT_HASH_ALG}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500152
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800153 dtb_loadline=""
154 dtb_ext=${DTB##*.}
155 if [ "${dtb_ext}" = "dtbo" ]; then
156 if [ -n "${UBOOT_DTBO_LOADADDRESS}" ]; then
157 dtb_loadline="load = <${UBOOT_DTBO_LOADADDRESS}>;"
158 fi
159 elif [ -n "${UBOOT_DTB_LOADADDRESS}" ]; then
160 dtb_loadline="load = <${UBOOT_DTB_LOADADDRESS}>;"
161 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500162 cat << EOF >> ${1}
163 fdt@${2} {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500164 description = "Flattened Device Tree blob";
George McCollister185c8ae2016-05-26 08:55:16 -0500165 data = /incbin/("${3}");
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500166 type = "flat_dt";
167 arch = "${UBOOT_ARCH}";
168 compression = "none";
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800169 ${dtb_loadline}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500170 hash@1 {
171 algo = "${dtb_csum}";
172 };
173 };
174EOF
175}
176
177#
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600178# Emit the fitImage ITS setup section
179#
180# $1 ... .its filename
181# $2 ... Image counter
182# $3 ... Path to setup image
183fitimage_emit_section_setup() {
184
Brad Bishopf3fd2882019-06-21 08:06:37 -0400185 setup_csum="${FIT_HASH_ALG}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600186
187 cat << EOF >> ${1}
188 setup@${2} {
189 description = "Linux setup.bin";
190 data = /incbin/("${3}");
191 type = "x86_setup";
192 arch = "${UBOOT_ARCH}";
193 os = "linux";
194 compression = "none";
195 load = <0x00090000>;
196 entry = <0x00090000>;
197 hash@1 {
198 algo = "${setup_csum}";
199 };
200 };
201EOF
202}
203
204#
George McCollister185c8ae2016-05-26 08:55:16 -0500205# Emit the fitImage ITS ramdisk section
206#
207# $1 ... .its filename
208# $2 ... Image counter
209# $3 ... Path to ramdisk image
210fitimage_emit_section_ramdisk() {
211
Brad Bishopf3fd2882019-06-21 08:06:37 -0400212 ramdisk_csum="${FIT_HASH_ALG}"
Nathan Rossib4a4dc02016-10-21 22:07:27 +1000213 ramdisk_loadline=""
214 ramdisk_entryline=""
215
216 if [ -n "${UBOOT_RD_LOADADDRESS}" ]; then
217 ramdisk_loadline="load = <${UBOOT_RD_LOADADDRESS}>;"
218 fi
219 if [ -n "${UBOOT_RD_ENTRYPOINT}" ]; then
220 ramdisk_entryline="entry = <${UBOOT_RD_ENTRYPOINT}>;"
221 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500222
223 cat << EOF >> ${1}
224 ramdisk@${2} {
Rick Altherrbc1b8802017-01-20 11:28:53 -0800225 description = "${INITRAMFS_IMAGE}";
George McCollister185c8ae2016-05-26 08:55:16 -0500226 data = /incbin/("${3}");
227 type = "ramdisk";
228 arch = "${UBOOT_ARCH}";
229 os = "linux";
Brad Bishop00e122a2019-10-05 11:10:57 -0400230 compression = "none";
Nathan Rossib4a4dc02016-10-21 22:07:27 +1000231 ${ramdisk_loadline}
232 ${ramdisk_entryline}
George McCollister185c8ae2016-05-26 08:55:16 -0500233 hash@1 {
234 algo = "${ramdisk_csum}";
235 };
236 };
237EOF
238}
239
240#
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500241# Emit the fitImage ITS configuration section
242#
George McCollister185c8ae2016-05-26 08:55:16 -0500243# $1 ... .its filename
244# $2 ... Linux kernel ID
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500245# $3 ... DTB image name
George McCollister185c8ae2016-05-26 08:55:16 -0500246# $4 ... ramdisk ID
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600247# $5 ... config ID
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500248# $6 ... default flag
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500249fitimage_emit_section_config() {
250
Brad Bishopf3fd2882019-06-21 08:06:37 -0400251 conf_csum="${FIT_HASH_ALG}"
Brad Bishop64c979e2019-11-04 13:55:29 -0500252 conf_sign_algo="${FIT_SIGN_ALG}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600253 if [ -n "${UBOOT_SIGN_ENABLE}" ] ; then
254 conf_sign_keyname="${UBOOT_SIGN_KEYNAME}"
255 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500256
257 # Test if we have any DTBs at all
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800258 sep=""
259 conf_desc=""
Andrew Geissler635e0e42020-08-21 15:58:33 -0500260 conf_node="conf@"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800261 kernel_line=""
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600262 fdt_line=""
263 ramdisk_line=""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500264 setup_line=""
265 default_line=""
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600266
Andrew Geissler635e0e42020-08-21 15:58:33 -0500267 # conf node name is selected based on dtb ID if it is present,
268 # otherwise its selected based on kernel ID
269 if [ -n "${3}" ]; then
270 conf_node=$conf_node${3}
271 else
272 conf_node=$conf_node${2}
273 fi
274
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800275 if [ -n "${2}" ]; then
276 conf_desc="Linux kernel"
277 sep=", "
278 kernel_line="kernel = \"kernel@${2}\";"
279 fi
280
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600281 if [ -n "${3}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800282 conf_desc="${conf_desc}${sep}FDT blob"
283 sep=", "
George McCollister185c8ae2016-05-26 08:55:16 -0500284 fdt_line="fdt = \"fdt@${3}\";"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600285 fi
286
287 if [ -n "${4}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800288 conf_desc="${conf_desc}${sep}ramdisk"
289 sep=", "
George McCollister185c8ae2016-05-26 08:55:16 -0500290 ramdisk_line="ramdisk = \"ramdisk@${4}\";"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500291 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600292
293 if [ -n "${5}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800294 conf_desc="${conf_desc}${sep}setup"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600295 setup_line="setup = \"setup@${5}\";"
296 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500297
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500298 if [ "${6}" = "1" ]; then
Andrew Geissler635e0e42020-08-21 15:58:33 -0500299 # default node is selected based on dtb ID if it is present,
300 # otherwise its selected based on kernel ID
301 if [ -n "${3}" ]; then
302 default_line="default = \"conf@${3}\";"
303 else
304 default_line="default = \"conf@${2}\";"
305 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500306 fi
307
George McCollister185c8ae2016-05-26 08:55:16 -0500308 cat << EOF >> ${1}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500309 ${default_line}
Andrew Geissler635e0e42020-08-21 15:58:33 -0500310 $conf_node {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500311 description = "${6} ${conf_desc}";
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500312 ${kernel_line}
313 ${fdt_line}
George McCollister185c8ae2016-05-26 08:55:16 -0500314 ${ramdisk_line}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600315 ${setup_line}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500316 hash@1 {
317 algo = "${conf_csum}";
318 };
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600319EOF
320
321 if [ ! -z "${conf_sign_keyname}" ] ; then
322
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800323 sign_line="sign-images = "
324 sep=""
325
326 if [ -n "${2}" ]; then
327 sign_line="${sign_line}${sep}\"kernel\""
328 sep=", "
329 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600330
331 if [ -n "${3}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800332 sign_line="${sign_line}${sep}\"fdt\""
333 sep=", "
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600334 fi
335
336 if [ -n "${4}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800337 sign_line="${sign_line}${sep}\"ramdisk\""
338 sep=", "
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600339 fi
340
341 if [ -n "${5}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800342 sign_line="${sign_line}${sep}\"setup\""
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600343 fi
344
345 sign_line="${sign_line};"
346
347 cat << EOF >> ${1}
348 signature@1 {
Brad Bishop64c979e2019-11-04 13:55:29 -0500349 algo = "${conf_csum},${conf_sign_algo}";
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600350 key-name-hint = "${conf_sign_keyname}";
351 ${sign_line}
352 };
353EOF
354 fi
355
356 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500357 };
358EOF
359}
360
George McCollister185c8ae2016-05-26 08:55:16 -0500361#
362# Assemble fitImage
363#
364# $1 ... .its filename
365# $2 ... fitImage name
366# $3 ... include ramdisk
367fitimage_assemble() {
368 kernelcount=1
369 dtbcount=""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500370 DTBS=""
George McCollister185c8ae2016-05-26 08:55:16 -0500371 ramdiskcount=${3}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600372 setupcount=""
George McCollister185c8ae2016-05-26 08:55:16 -0500373 rm -f ${1} arch/${ARCH}/boot/${2}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500374
George McCollister185c8ae2016-05-26 08:55:16 -0500375 fitimage_emit_fit_header ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500376
George McCollister185c8ae2016-05-26 08:55:16 -0500377 #
378 # Step 1: Prepare a kernel image section.
379 #
380 fitimage_emit_section_maint ${1} imagestart
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500381
George McCollister185c8ae2016-05-26 08:55:16 -0500382 uboot_prep_kimage
383 fitimage_emit_section_kernel ${1} "${kernelcount}" linux.bin "${linux_comp}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500384
George McCollister185c8ae2016-05-26 08:55:16 -0500385 #
386 # Step 2: Prepare a DTB image section
387 #
Brad Bishop19323692019-04-05 15:28:33 -0400388
389 if [ -z "${EXTERNAL_KERNEL_DEVICETREE}" ] && [ -n "${KERNEL_DEVICETREE}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500390 dtbcount=1
George McCollister185c8ae2016-05-26 08:55:16 -0500391 for DTB in ${KERNEL_DEVICETREE}; do
392 if echo ${DTB} | grep -q '/dts/'; then
393 bbwarn "${DTB} contains the full path to the the dts file, but only the dtb name should be used."
394 DTB=`basename ${DTB} | sed 's,\.dts$,.dtb,g'`
395 fi
396 DTB_PATH="arch/${ARCH}/boot/dts/${DTB}"
397 if [ ! -e "${DTB_PATH}" ]; then
398 DTB_PATH="arch/${ARCH}/boot/${DTB}"
399 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500400
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500401 DTB=$(echo "${DTB}" | tr '/' '_')
402 DTBS="${DTBS} ${DTB}"
403 fitimage_emit_section_dtb ${1} ${DTB} ${DTB_PATH}
George McCollister185c8ae2016-05-26 08:55:16 -0500404 done
405 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500406
Brad Bishop19323692019-04-05 15:28:33 -0400407 if [ -n "${EXTERNAL_KERNEL_DEVICETREE}" ]; then
408 dtbcount=1
Andrew Geissler82c905d2020-04-13 13:39:40 -0500409 for DTB in $(find "${EXTERNAL_KERNEL_DEVICETREE}" \( -name '*.dtb' -o -name '*.dtbo' \) -printf '%P\n' | sort); do
Brad Bishop19323692019-04-05 15:28:33 -0400410 DTB=$(echo "${DTB}" | tr '/' '_')
411 DTBS="${DTBS} ${DTB}"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500412 fitimage_emit_section_dtb ${1} ${DTB} "${EXTERNAL_KERNEL_DEVICETREE}/${DTB}"
Brad Bishop19323692019-04-05 15:28:33 -0400413 done
414 fi
415
George McCollister185c8ae2016-05-26 08:55:16 -0500416 #
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600417 # Step 3: Prepare a setup section. (For x86)
418 #
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500419 if [ -e arch/${ARCH}/boot/setup.bin ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600420 setupcount=1
421 fitimage_emit_section_setup ${1} "${setupcount}" arch/${ARCH}/boot/setup.bin
422 fi
423
424 #
425 # Step 4: Prepare a ramdisk section.
George McCollister185c8ae2016-05-26 08:55:16 -0500426 #
427 if [ "x${ramdiskcount}" = "x1" ] ; then
Rick Altherrbc1b8802017-01-20 11:28:53 -0800428 # Find and use the first initramfs image archive type we find
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800429 for img in cpio.lz4 cpio.lzo cpio.lzma cpio.xz cpio.gz ext2.gz cpio; do
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500430 initramfs_path="${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE_NAME}.${img}"
Rick Altherrbc1b8802017-01-20 11:28:53 -0800431 echo "Using $initramfs_path"
432 if [ -e "${initramfs_path}" ]; then
433 fitimage_emit_section_ramdisk ${1} "${ramdiskcount}" "${initramfs_path}"
434 break
435 fi
436 done
George McCollister185c8ae2016-05-26 08:55:16 -0500437 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500438
George McCollister185c8ae2016-05-26 08:55:16 -0500439 fitimage_emit_section_maint ${1} sectend
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500440
George McCollister185c8ae2016-05-26 08:55:16 -0500441 # Force the first Kernel and DTB in the default config
442 kernelcount=1
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500443 if [ -n "${dtbcount}" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600444 dtbcount=1
445 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500446
George McCollister185c8ae2016-05-26 08:55:16 -0500447 #
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600448 # Step 5: Prepare a configurations section
George McCollister185c8ae2016-05-26 08:55:16 -0500449 #
450 fitimage_emit_section_maint ${1} confstart
451
Andrew Geissler635e0e42020-08-21 15:58:33 -0500452 # kernel-fitimage.bbclass currently only supports a single kernel (no less or
453 # more) to be added to the FIT image along with 0 or more device trees and
454 # 0 or 1 ramdisk.
455 # If a device tree is to be part of the FIT image, then select
456 # the default configuration to be used is based on the dtbcount. If there is
457 # no dtb present than select the default configuation to be based on
458 # the kernelcount.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500459 if [ -n "${DTBS}" ]; then
460 i=1
461 for DTB in ${DTBS}; do
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800462 dtb_ext=${DTB##*.}
463 if [ "${dtb_ext}" = "dtbo" ]; then
464 fitimage_emit_section_config ${1} "" "${DTB}" "" "" "`expr ${i} = ${dtbcount}`"
465 else
466 fitimage_emit_section_config ${1} "${kernelcount}" "${DTB}" "${ramdiskcount}" "${setupcount}" "`expr ${i} = ${dtbcount}`"
467 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500468 i=`expr ${i} + 1`
469 done
Andrew Geissler635e0e42020-08-21 15:58:33 -0500470 else
471 defaultconfigcount=1
472 fitimage_emit_section_config ${1} "${kernelcount}" "" "${ramdiskcount}" "${setupcount}" "${defaultconfigcount}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500473 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500474
475 fitimage_emit_section_maint ${1} sectend
476
477 fitimage_emit_section_maint ${1} fitend
478
479 #
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600480 # Step 6: Assemble the image
George McCollister185c8ae2016-05-26 08:55:16 -0500481 #
482 uboot-mkimage \
483 ${@'-D "${UBOOT_MKIMAGE_DTCOPTS}"' if len('${UBOOT_MKIMAGE_DTCOPTS}') else ''} \
484 -f ${1} \
485 arch/${ARCH}/boot/${2}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600486
487 #
488 # Step 7: Sign the image and add public key to U-Boot dtb
489 #
490 if [ "x${UBOOT_SIGN_ENABLE}" = "x1" ] ; then
Brad Bishop19323692019-04-05 15:28:33 -0400491 add_key_to_u_boot=""
492 if [ -n "${UBOOT_DTB_BINARY}" ]; then
493 # The u-boot.dtb is a symlink to UBOOT_DTB_IMAGE, so we need copy
494 # both of them, and don't dereference the symlink.
495 cp -P ${STAGING_DATADIR}/u-boot*.dtb ${B}
496 add_key_to_u_boot="-K ${B}/${UBOOT_DTB_BINARY}"
497 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600498 uboot-mkimage \
499 ${@'-D "${UBOOT_MKIMAGE_DTCOPTS}"' if len('${UBOOT_MKIMAGE_DTCOPTS}') else ''} \
500 -F -k "${UBOOT_SIGN_KEYDIR}" \
Brad Bishop19323692019-04-05 15:28:33 -0400501 $add_key_to_u_boot \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600502 -r arch/${ARCH}/boot/${2}
503 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500504}
505
506do_assemble_fitimage() {
507 if echo ${KERNEL_IMAGETYPES} | grep -wq "fitImage"; then
508 cd ${B}
509 fitimage_assemble fit-image.its fitImage
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500510 fi
511}
512
513addtask assemble_fitimage before do_install after do_compile
514
George McCollister185c8ae2016-05-26 08:55:16 -0500515do_assemble_fitimage_initramfs() {
516 if echo ${KERNEL_IMAGETYPES} | grep -wq "fitImage" && \
517 test -n "${INITRAMFS_IMAGE}" ; then
518 cd ${B}
519 fitimage_assemble fit-image-${INITRAMFS_IMAGE}.its fitImage-${INITRAMFS_IMAGE} 1
520 fi
521}
522
Brad Bishop19323692019-04-05 15:28:33 -0400523addtask assemble_fitimage_initramfs before do_deploy after do_bundle_initramfs
George McCollister185c8ae2016-05-26 08:55:16 -0500524
525
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500526kernel_do_deploy[vardepsexclude] = "DATETIME"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500527kernel_do_deploy_append() {
528 # Update deploy directory
He Zhefe76b1e2016-05-25 04:47:16 -0400529 if echo ${KERNEL_IMAGETYPES} | grep -wq "fitImage"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500530 echo "Copying fit-image.its source file..."
Brad Bishop64c979e2019-11-04 13:55:29 -0500531 install -m 0644 ${B}/fit-image.its "$deployDir/fitImage-its-${KERNEL_FIT_NAME}.its"
532 ln -snf fitImage-its-${KERNEL_FIT_NAME}.its "$deployDir/fitImage-its-${KERNEL_FIT_LINK_NAME}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800533
534 echo "Copying linux.bin file..."
Brad Bishop64c979e2019-11-04 13:55:29 -0500535 install -m 0644 ${B}/linux.bin $deployDir/fitImage-linux.bin-${KERNEL_FIT_NAME}.bin
536 ln -snf fitImage-linux.bin-${KERNEL_FIT_NAME}.bin "$deployDir/fitImage-linux.bin-${KERNEL_FIT_LINK_NAME}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500537
George McCollister185c8ae2016-05-26 08:55:16 -0500538 if [ -n "${INITRAMFS_IMAGE}" ]; then
539 echo "Copying fit-image-${INITRAMFS_IMAGE}.its source file..."
Brad Bishop64c979e2019-11-04 13:55:29 -0500540 install -m 0644 ${B}/fit-image-${INITRAMFS_IMAGE}.its "$deployDir/fitImage-its-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.its"
541 ln -snf fitImage-its-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.its "$deployDir/fitImage-its-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_LINK_NAME}"
George McCollister185c8ae2016-05-26 08:55:16 -0500542
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800543 echo "Copying fitImage-${INITRAMFS_IMAGE} file..."
Brad Bishop64c979e2019-11-04 13:55:29 -0500544 install -m 0644 ${B}/arch/${ARCH}/boot/fitImage-${INITRAMFS_IMAGE} "$deployDir/fitImage-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.bin"
545 ln -snf fitImage-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.bin "$deployDir/fitImage-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_LINK_NAME}"
George McCollister185c8ae2016-05-26 08:55:16 -0500546 fi
Brad Bishop19323692019-04-05 15:28:33 -0400547 if [ "${UBOOT_SIGN_ENABLE}" = "1" -a -n "${UBOOT_DTB_BINARY}" ] ; then
548 # UBOOT_DTB_IMAGE is a realfile, but we can't use
549 # ${UBOOT_DTB_IMAGE} since it contains ${PV} which is aimed
550 # for u-boot, but we are in kernel env now.
Brad Bishop64c979e2019-11-04 13:55:29 -0500551 install -m 0644 ${B}/u-boot-${MACHINE}*.dtb "$deployDir/"
Brad Bishop19323692019-04-05 15:28:33 -0400552 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500553 fi
554}