blob: 1961bb5b31f6d0603594f9084a66d8c5387c7d84 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
Brad Bishopf3fd2882019-06-21 08:06:37 -040011SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
Brad Bishop6dbb3162019-11-25 09:41:34 -050012 "
Brad Bishop19323692019-04-05 15:28:33 -040013
Brad Bishop6dbb3162019-11-25 09:41:34 -050014SRC_URI[md5sum] = "db8765c8d076f1b6caafd9f2542a304a"
15SRC_URI[sha256sum] = "98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f"
Brad Bishop19323692019-04-05 15:28:33 -040016
17UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
18
19S = "${WORKDIR}/libxslt-${PV}"
20
21BINCONFIG = "${bindir}/xslt-config"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
Brad Bishop19323692019-04-05 15:28:33 -040024
Brad Bishop19323692019-04-05 15:28:33 -040025do_configure_prepend () {
Brad Bishop15ae2502019-06-18 21:44:24 -040026 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
27 # This can be removed when upgrading to 1.1.34.
Brad Bishop19323692019-04-05 15:28:33 -040028 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
29
30 # The timestamps in the 1.1.28 tarball are messed up causing this file to
31 # appear out of date. Touch it so that we don't try to regenerate it.
32 touch ${S}/doc/xsltproc.1
33}
34
35EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
36# older versions of this recipe had ${PN}-utils
37RPROVIDES_${PN}-bin += "${PN}-utils"
38RCONFLICTS_${PN}-bin += "${PN}-utils"
39RREPLACES_${PN}-bin += "${PN}-utils"
40
41# This is only needed until libxml can load the relocated catalog itself
42do_install_append_class-native () {
43 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
44}
45
Andrew Geissler82c905d2020-04-13 13:39:40 -050046do_install_append () {
47 oe_multilib_header libxslt/xsltconfig.h
48}
49
Brad Bishop19323692019-04-05 15:28:33 -040050FILES_${PN} += "${libdir}/libxslt-plugins"
51FILES_${PN}-dev += "${libdir}/xsltConf.sh"
52
53BBCLASSEXTEND = "native nativesdk"