blob: 3efd2a9b3520b94b7ece3b80ebe72355650e1e7e [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "GNOME editor"
2SECTION = "x11/gnome"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8DEPENDS = " \
9 gdk-pixbuf-native \
10 gtk+3 \
11 gsettings-desktop-schemas \
12 libpeas \
13 libsoup-2.4 \
14 gspell \
15 gtksourceview4 \
16 tepl \
17"
18
19inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig
20
21def gnome_verdir(v):
22 return oe.utils.trim_version(v, 1)
23
Andrew Geissler78b72792022-06-14 06:47:25 -050024SRC_URI[archive.sha256sum] = "7f1fd43df5110d4c37de6541993f41f0fbc3efc790900e92053479ba069920e9"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000025
26# gobject-introspection is mandatory and cannot be configured
Andrew Geissler78b72792022-06-14 06:47:25 -050027REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
28ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
29
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000030GIR_MESON_OPTION = ""
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33
34PACKAGES += "${PN}-python"
35
36FILES:${PN} += " \
37 ${datadir}/dbus-1 \
38 ${datadir}/metainfo \
39"
40
41FILES:${PN}-python += " \
42 ${PYTHON_SITEPACKAGES_DIR} \
43"
44
45RDEPENDS:${PN} += "gsettings-desktop-schemas"
46RRECOMMENDS:${PN} += "source-code-pro-fonts"