blob: 5eb9ec1bfc776fe2d647fd427bdf7cec91d8b325 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Unbound is a validating, recursive, and caching DNS resolver"
2DESCRIPTION = "Unbound's design is a set of modular components which incorporate \
3 features including enhanced security (DNSSEC) validation, Internet Protocol \
4 Version 6 (IPv6), and a client resolver library API as an integral part of the \
5 architecture"
6
7HOMEPAGE = "https://www.unbound.net/"
8SECTION = "net"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=5308494bc0590c0cb036afd781d78f06"
11
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/NLnetLabs/unbound.git;protocol=http;branch=master;protocol=https \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060013 file://0001-contrib-add-yocto-compatible-init-script.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040014"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050015SRCREV = "903538c76e1d8eb30d0814bb55c3ef1ea28164e8"
Brad Bishop26bdd442019-08-16 17:08:17 -040016
17inherit autotools pkgconfig systemd update-rc.d
18
19DEPENDS = "openssl libevent libtool-native bison-native expat"
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} = "bash openssl-bin daemonize"
Brad Bishop26bdd442019-08-16 17:08:17 -040021
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF = "--with-libexpat=${STAGING_EXECPREFIXDIR} \
Andrew Geissler595f6302022-01-24 19:11:47 +000025 --with-ssl=${STAGING_EXECPREFIXDIR}"
Brad Bishop26bdd442019-08-16 17:08:17 -040026
27
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile systemd', d)}"
29PACKAGECONFIG[dnscrypt] = "--enable-dnscrypt, --disable-dnscrypt, libsodium"
30PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
31PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
32
Patrick Williams213cb262021-08-07 19:21:33 -050033do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040034 install -d ${D}${systemd_unitdir}/system
35 install -m 0644 ${B}/contrib/unbound.service ${D}${systemd_unitdir}/system
36
37 install -d ${D}${sysconfdir}/init.d
38 install -m 0755 ${S}/contrib/unbound.init ${D}${sysconfdir}/init.d/unbound
39}
40
Patrick Williams213cb262021-08-07 19:21:33 -050041SYSTEMD_SERVICE:${PN} = "${BPN}.service"
Brad Bishop26bdd442019-08-16 17:08:17 -040042
43INITSCRIPT_NAME = "unbound"
44INITSCRIPT_PARAMS = "defaults"