blob: b231cc287877208cc21d5c413e4a159fc8840387 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Fast Log processor and Forwarder"
2DESCRIPTION = "Fluent Bit is a data collector, processor and \
3forwarder for Linux. It supports several input sources and \
4backends (destinations) for your data. \
5"
6
7HOMEPAGE = "http://fluentbit.io"
8BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
12SECTION = "net"
13
14SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \
15 file://jemalloc.patch \
16 file://cross-build-init-system-detection.patch \
17 file://builtin-nan.patch \
Brad Bishop0e2770c2020-01-21 07:31:46 -050018 file://0001-ppc-Fix-signature-for-co_create-API.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060019 file://0001-bin-fix-SIGSEGV-caused-by-using-flb_free-instead-of-.patch \
20 file://0002-parser-Fix-SIGSEGV-caused-by-using-flb_free-instead-.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050021 file://0001-Control-sytemd-unit-install-location-with-SYSTEM_DIR.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060022 "
Brad Bishope42b3e32020-01-15 22:08:42 -050023SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747"
24SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789"
25
26S = "${WORKDIR}/fluent-bit-${PV}"
27DEPENDS = "zlib bison-native flex-native"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060028DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030DEPENDS:append:libc-musl = " fts "
Brad Bishope42b3e32020-01-15 22:08:42 -050031
Patrick Williams213cb262021-08-07 19:21:33 -050032INSANE_SKIP:${PN}-dev += "dev-elf"
Brad Bishope42b3e32020-01-15 22:08:42 -050033
Andrew Geissler4b7c1152020-11-30 19:55:29 -060034LTO = ""
35
Brad Bishope42b3e32020-01-15 22:08:42 -050036# Use CMake 'Unix Makefiles' generator
37OECMAKE_GENERATOR ?= "Unix Makefiles"
38
39# Fluent Bit build options
40# ========================
41
42# Host related setup
43EXTRA_OECMAKE += "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1"
44
45# Disable LuaJIT and filter_lua support
46EXTRA_OECMAKE += "-DFLB_LUAJIT=Off -DFLB_FILTER_LUA=Off "
47
48# Disable Library and examples
49EXTRA_OECMAKE += "-DFLB_SHARED_LIB=Off -DFLB_EXAMPLES=Off "
50
Patrick Williams03907ee2022-05-01 06:28:52 -050051# Enable systemd iff systemd is in DISTRO_FEATURES
52EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES','systemd','-DFLB_SYSTEMD=On -DSYSTEMD_DIR=${systemd_system_unitdir}','-DFLB_SYSTEMD=Off',d)}"
Brad Bishope42b3e32020-01-15 22:08:42 -050053
Patrick Williams213cb262021-08-07 19:21:33 -050054EXTRA_OECMAKE:append:riscv64 = " -DFLB_DEPS='atomic'"
55EXTRA_OECMAKE:append:riscv32 = " -DFLB_DEPS='atomic'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050056
Brad Bishope42b3e32020-01-15 22:08:42 -050057# Kafka Output plugin (disabled by default): note that when
58# enabling Kafka output plugin, the backend library librdkafka
59# requires 'openssl' as a dependency.
60#
61# DEPENDS += "openssl "
62# EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On "
63
Andrew Geissler89770b02020-06-13 10:40:47 -050064inherit cmake systemd
Brad Bishope42b3e32020-01-15 22:08:42 -050065
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050066CFLAGS += "-fcommon"
67
Patrick Williams213cb262021-08-07 19:21:33 -050068SYSTEMD_SERVICE:${PN} = "td-agent-bit.service"
69TARGET_CC_ARCH:append = " ${SELECTED_OPTIMIZATION}"